Synchronizing and export doesn't work

I have tried now several times to export my keys to a file. Nothing happens when I click export button. Absolutely nothing. So no exports and my keys are only in this software.

Then I bought premium version so that I can even sync everything with my tablet and phone. First time everything worked fine. After few new releases Connect devices stopped working. I give the code from my computers Key Software and press connect button and then it says wait and freezes. 

That is if the software even opens in my android phone. Only the logo window is shown and that's it. I have to re-install it several times and everytime the passwords should be Synchronized but how can I do it because it doesn't work. 

I really can't recommend this product to anyone nor pay anything for premium. I take my money to somewhere else

Accepted Answer


  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Linsus,


    Sorry to hear that you have a hard-time synchronizing and exporting your data.

    Could you tell us which versions you do use on your desktop and Android phone?


    Did you already follow both this and this article?


    Did you have our Technology Preview version in use at anytime? This could cause some synchronization issue.


  • linsuslinsus Posts: 9

    I have tried both articles. 

    First one stops in step 3. There is never any saving dialog shown. I have HP Pavilion 17 Notebook PC and Windows 8.1 64-bittinen.

    Second stops in step 5. I never get question about the master password. I have Samsung GT-I9195 and Android version 4.4.2.

    Desktop version is downloaded from f-secure site and android version from play store

  • BenBen Posts: 2,641 F-Secure Product Expert

    We released recently new versions  of KEY, could you tell us which one you have currently in use?

  • linsuslinsus Posts: 9

    I got version 3.0.112 but previous version didn't work either. My mom tried exporting with previous version with Acer computer and she could do it

  • UkkoUkko Posts: 3,220 Superuser



    Sorry for my reply. Maybe I have experience about something same.

    Today I goes to check new version of Key (3.0.112) and get a lot of strange points around.


    Also it's can be related with your description. Such as one of "strange points" - buttons, which not work (not just export, but also create-password or other). There have visible "indicator" of trouble-stuck-point, but I thought.. that it's can be just my local experience.


    Anyway.. can be helpful (I talk just about Windows client.. not try it with other platforms about recent versions) with your situations next steps:

    -> Launch Key UI, Enter by master-password, goes to "Lock"-feature.

    -> Entering again to Key.

    -> Export should to work after that?


    It was my steps.. for "re-stuck" situation around UI.. with first launch after "installation". And my experience about "each first" launch comes with stuck about a lot of features and some of "UI"-troubles.

    "Lock" from settings part.. work as "fix" this (if it's not shut down/quit between).

  • dukavidukavi Posts: 113 F-Secure Employee

    UI problems may be related to specific OS settings, because normally it should work just fine. We will take a look into it.

  • UkkoUkko Posts: 3,220 Superuser

    Maybe it's not really UI problems. With my experience.. I call like that something next:


    -> for example... there visible settings/words, which probably should be hidden (?!). Such as it's not work and when all OK - current part of words missing (under UI). It's about autofill and some other places.


    -> Short-briefly skip-action for "Master Password Recovery picture".


    -> if I have passwords.... it will be not visible.


    -> "license" goes to be not a premium. and any of "codes" will be not work. or temporary work for session. Such as "total stuck".


    I thought about local experience. But I did "uninstallation" after that.... also goes to use F-Secure Uninstall TOOL (as F-Secure Key removed by tool too).

    And install it again after that.


    Situation with my experience... same.


    Launch as fresh installation. All OK (probably there), but usually I close it from first and run again.


    With current "next" run and each one next first launch will be with strange poitns around.


    -> UI have settings, which not available to use (autofill option, but it's goes to be not a valid after choose) and view with some of other information around (if there was valid license - information goes to be dropped).


    -> Not able to use any of buttons (export or other).


    -> But available to use "Lock' and entering to Key again (per launch - not shut down between) and F-Secure Key work normally.


    But next "launch" (after quit) with same experience again.


    Sorry for my reply.

  • UkkoUkko Posts: 3,220 Superuser



    Sorry for over-the-words.


    Just as additional for my experience/situation.


    There two different steps (for normal behavior and for strange one):

    --laptop Windows--

    -> You add master password to form... and:


    --> If you choose "Enter" - all OK.


    --> if you choose "enter-button" (as Key-picture) by mouse or touchpad.... will be "strange situation" with points from previous description.


    It's looks like that there stable behavior for current "different"-result by two various types of entering.

    Not sure that there can be double-click-choose or something else (but I tried touch-pad and mouse - same strange situation;  Entering by "Enter" from keyboard - normal situation).


    Sorry again.

  • BruceBruce Posts: 18

    I am having the same issue after doing an upgrade today. I have tried to sync my android to my PC by inputting the code from "sync devices" on my PC into my Moto G. The screen freezes and the Moto G is not synced to the passwords on my computer.

  • JassuJassu Posts: 43 Observer

    100% same here. Export wont work anymore with Windows 8.1 64 Bit, also the sync with android is not working - have not been working since license upgrade (i had to buy new license because old expired and renewal did not work).

  • linsuslinsus Posts: 9

    waiting for solution still

  • BenBen Posts: 2,641 F-Secure Product Expert



    we are still working on the export issue. We will keep you informed on that one.

  • BruceBruce Posts: 18

    thank you

  • dukavidukavi Posts: 113 F-Secure Employee

    New version is avaliable now (3.1.106).

    It should fix a problem with exporting passwords.

    You should receive notiffication when you run application, please download and install the product.


  • BruceBruce Posts: 18

    I got the notification when I logged in on my computer and nothing happened when I clicked to download. I can't wait any longer for you to fix this problem and will have to use another option for managing my passwords. I am VERY frustrated with thids. How could you release an upgrade without checking to see if it works?????????

  • BruceBruce Posts: 18

    OK- I downloaded the new version and went to sync my computer with my android. I clicked to generate the code on my computer and entered it into my android. My android has been displaying "connecting" for the past five minutes. I cannot sync my android with the data on my computer. Was this usupposed to be fixed with the update I was notified of today 05.21.2015?

  • linsuslinsus Posts: 9

    Now export works. Thank you for that.

    Connecting computer and android phone doesn't work. Difference between now and before is that application asks master password that I use in my computer but then wait...connecting... screen stays forerver so that doesn't work

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Bruce, Linsus,


    Could you confirm which version  of the Key you are currently running on your Android?

    Lots of syncing issue should be resolved with the latest version release for this platform.

  • BruceBruce Posts: 18


  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello bruce,


    There is a new version(3.1.1) coming in the next few days that should resolve syncing issues.

  • BruceBruce Posts: 18
    The issue has been resolved with the latest release
  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Bruce,


    Thank you for the follow up.

  • linsuslinsus Posts: 9

    Still doesn't work for android. I installed new version but sync goes on and on for 5min now. I don't have that many passwords to sync

  • BenBen Posts: 2,641 F-Secure Product Expert



    Could you remind us of the set up you now have?

    Devices, OS, key version and are the devices premium or free?



  • linsuslinsus Posts: 9

    I have HP Pavilion 17 Notebook PC and Windows 8.1 64-bit with f-secure key premium 3.1.112 and android 4.4.2, phone model Samsung GT-I9195 with f-secure key 3.1.2. I had to install it 3 times in my phone because the app didn't start at all. 

  • linsuslinsus Posts: 9
    and now the windows version of key says that I don't have premium anymore even that my license is still valid. Nothing works with this app
This discussion has been closed.