Icon disappeared form fields and selecting value from dropdown forced by Ctrl+F2 does not work aymor

Hi,

 

I have been using F-Secure Key for quite some time, but recently it stopped working correctly on Windows 8.1. I am experiencing these issues (using Internet Explorer, but same happens with Chrome):

 

1. The Key icon pointing to dropdown list with entries does not show in any field anymore.

2. When I press Ctrl+F2, the dropdown selection with passwords appears, but it is not under the field where it used to be, but it appears randomly somewhere in the middle of my screen.

3. When I select value from the list, nothing is filled into the field within browser. Simply nothing happens.

 

I would like to resolve these three issues. I have some other weird observations which might help to find the root cause. Behavior is different depending on application used. Notepad can be used as a reference as it seems to work correctly (didn't work before, but started working after reinstall of F-Secure).

 

Call dropdown list with Ctrl+F2 and Click on item in the list

  • Editbox in IE: does nothing
  • Notepad: deletes whatever text was within notepad file before, fills my username and sends Tab key
  • Microsoft Word: does nothing

Call list with Ctrl+F2 and Shift+Click on item in the list

  • Editbox in IE: fills username
  • Notepad: fills username
  • Microsoft Word: fills username twice with no space in between

 

Call list with Ctrl+F2 and Ctrl+Click on item in the list

  • Editbox in IE: fills password
  • Notepad: fills password
  • Microsoft Word: sometimes does nothing, sometimes fills first letter or first few letters of password, sometimes fills entire password+some first few letters from password again attempting to fill password twice - it seems really random as I always use same password

Call list with Ctrl+F2 and Shift+Ctrl+Click on item in the list

  • Editbox in IE: fills username and password both within the same field without any space in between and probably sends Enter key as I get wrong password error afterwards
  • Notepad: fills username, then Enter key, then password and Enter key again
  • Microsoft Word: fills random number of first letters from string consisting of username filled twice, then next line and random number of first letters from password twice

 

WORKAROUND

For now I use workaround with Shift+Click and Ctrl+Click, but I have to call dropdown list twice once for username field and once for password field, but this is really painful especially when I use tablet and I need to scroll the list with tiny scrollbar and my huge finger Smiley Frustrated

 

I will welcome any solution suggestion. Thanks in advance for your help.

Comments

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    Sorry for my reply.

    I can just to think about one of points around, but.. it's probably can not be related with your situation... just because.. you have experience.. when "hotkeys" for fill.. work there.

     

    Anyway - part of description can be repeated.. if your browsers launched with administrators rights (as example) under account with UAC (as example). It's mean will be different rights for F-Secure Key and for Browser. And Key not able to fill anything.

    But with my experience.... if it's related with current point.... "CTRL+F2" + "any of fill-keys"... should be not work too (?!).

    OR maybe there have any software, which can to create some kind of "protection" for browsers?! Any tools like MBAE, EMET or something same. Anyway - maybe it's something specific for Windows 8.1 and there should be response from F-Secure Key team;

    If with other part of applications (just because it's looks like work normally) can be all OK!? Maybe there indeed can be something specific.

     

    For example... not sure about Microsoft Word (?), but with WordPad will be same experience for me too.

    And it's from first versions of Key. All other behavior also related with my experience or with design of Key (I mean - Notepad design and design of fill-actions).

     

    With WordPad's strange-view of filling... also was some dreams around.

    Probably I stopped on point.. that it's can be related with two "clipboards" history... and Key filling both of them. And it will be double-filling, which can be "close to random" view of filling. I stop thought about it... some months ago... when created steps and some kind of "visible" reason of "why it's happened"... and forget about it. Now.. with brief trying to re-get "point, which I think can be a reason"...  maybe I already forget the point.

     

    Sorry for my reply again.

  • brutebrute Posts: 2

    Hi Ukko,

     

    Thanks for your response, I gave me several ideas on what to try.

     

    First of all, I tried to run the browser as an administrator and I confirm that nothing is filled into fields in this case, not even with Ctrl or Shift combinations. So having different rights does not seem to be the root cause as the impact is different.

     

    I also tried to disable all "protection" tools and antivirus, but there is still no difference.

     

    What I also tested is that I have the same experience with any browser field, also the editor on this website where I am posting this reply.  So I tend to think that this might be somehow related to .NET framework or some other core component which is reused by both browsers (IE and Chrome) to handle content in edit box. So I will try to uninstall recent Windows updates related to .NET framework to see if it helps.

     

    Thanks for alll the suggestions.

     

     

This discussion has been closed.