service unavailable

Hy,

 

I have problem witm PMC.Capture.PNG

I tried to like it is described in https://community.f-secure.com/t5/Business/F-secure-policy-manager-console/m-p/32299#M921 but no lck.

Here is SS from status monitor.

Capture2.PNG

If you need any other log file, I can sent id to you.

 

This is quite problem since I can't administrate my AV.

 

Kind regards

Comments

  • ChuChu Posts: 49

    Hi,

     

    Are you already checked if the service of F-Secure Policy Manager Server is in execution?

    services.JPG

    Att,

     

    Roberto Chu

     

  • Yes. I check it. It is in starterd mode.

    I also made restar (stop + start) and it is started again with no erros in windows logging.

     

    Capture3.PNG

  • ChuChu Posts: 49

    In this case, as you said you just updated your F-Secure, I suggest you made a backup of database and after this, use database recovery tool. Its seems database corrupt.

     

    ftp://ftp.f-secure.com/support/tools/pm/recovery-tool/fspm-db-recovery-tool.11.30.61100.zip

     

    Att,

     

    Roberto Chu

     

  • I had tied to do that. But no luck.

    This is fist line from repair log:

     

    26.03.2015 13:26:05,565 ERROR [com.fsecure.fspms.db.recovery.FspmsDbVersionSelector] - Cannot retrieve old database schema revision, using latest v.43
    org.springframework.jdbc.CannotGetJdbcConnectionException: Could not get JDBC Connection; nested exception is org.h2.jdbc.JdbcSQLException: General error: "java.lang.RuntimeException: page[2081146] data leaf table:53 T53 entries:1 parent:2036544 keys:[6419845] offsets:[1686] parent 2036544 expected 2041674" [50000-164]

     

    I can't upload recovery.log file rehe.

     

  • ChuChu Posts: 49

    Seems your Policy Manager aome way still using version 9 database.

     

    I remember in the "old" Policy Manager version have a application to convert database version 9 to 10. Try find this application (its inside old version of Policy Manager - I think Policy Manager 10.x) and use over you OLD database (the version 9). This application will convert to database version 10 and after this, you can apply the new Policy Manager (version 11).

     

    If even after all this procedure, if you still problem to convert the database, open a ticket to support and send to them the database.

     

    Att,

     

    Roberto Chu

  • We haven't do upgrade.
    This is fresh installation version 11.10. It was in operation for a couple of months and yesterday we noticed this.

  • ChuChu Posts: 49

    My suggestion is open a ticket to support. My concern is your database cant be recovered (as you said).

    Dont worth try update to Policy Manager 11.30, if you try to update, probably dont work the database conversion to 11.30 version.

This discussion has been closed.