Key forgot my premium subscription

My desktop computers suddenly lost my subscription (premium changed to free) and I can't sync my phone anymore to the desktop clients as the desktop clients think that I don't have an active subscription.

 

My iPhone still says KEY Premium and i can see my subscription in iTunes as active (20 October 2015 is the next renewal).

 

This might be related to the recent removal of my Younited account, but I'm just guessing here.

 

OSX client is of version 2.0.129

and the iPhone client 2.1.2

Comments

  • Jarad01Jarad01 Posts: 2

    The exact same thing happened to me this week using a Windows 7 laptop. On my iPhone I have F-Secure Key version 2.1.2.

     

    Windows laptop says my subscription is expired.

     

    iPhone app says I have Key Premium.

     

    Can anyone tell us what the fix for this is?

  • MrAx1nMrAx1n Posts: 8

    I have the same situation, only I got iPhone and Windows 7.

    I have an active subscription in my iPhone, but on my computer I get (after last upgrade) that I don't have an active subscription.

  • BenBen Posts: 2,640 F-Secure Product Expert

    Hi,

     

    Thank you for reporting the issue. Our development team is working on it and try to release a fix next week.

    Note that your data should still be safe on your other devices.

    MrAx1nmatiki
  • MrAx1nMrAx1n Posts: 8

    Today I got a subscription key to enter in my desktop installation. I generated a key on my computer and entered it on my iPhone. A bit scary because I didn't have any passwords on my computer, just on my iPhone.

    But it solved my problem! Now the sync work just as expected and I didn't lose any passwords.

  • BenBen Posts: 2,640 F-Secure Product Expert

    @MrAx1n Thank you for the follow up and glad that it is now sorted out for you.

  • matikimatiki Posts: 3

    I don't know who accepted the above as a solution, because it doesn't solve my issue here at all. I don't have any subscription keys here.

     

    Only the iTunes purchase and desktop clients that don't work as expected.

  • Jarad01Jarad01 Posts: 2

    I agree -- I have the exact same problem and there has not been a "solution" offered. F-Secure Key says I have premium status on my iOS device and says that I do not have premium status on my Windows device.

     

    I've not been provided with a solution, though I have seen some inapplicable commentary here that doesn't resolve anything for anyone.

    matiki
  • matikimatiki Posts: 3

    I've just sent the application log files to the HQ. Hopefully they reveal the issue and we could finally be done with this.

  • timstims Posts: 2

    Hi,

     

    the same thing happened to me. Bought the premium, installed on pc and Android phone, was able to link them and manage passwords and sync between the devices and server.

     

    Last Sat I tried after a longish break to use the Key on my pc, and it asked the master password and reverted to free version. There are no passwords, and the android phone is longer in the list of passwords. Seems like it lost  all the data on the installation configuration and my subscription.

     

    The Android phone version works fine, but getting nervous of losing access to my passwords if something happens to my mobile phone. That would be intolerable.

     

    Can anyone from F-Secure please help in getting back the premium subscription and the connection  with the Android phone?

     

    Interesting to find out there seems to be no regular support email or ticketing system for the Key, or at least not one that I can find easily. Had I realized that, I probably would not have selected the Key for my password management.

     

    Laptop running Windows 7, Key 2.0.145

    Phone running Android 4.4.4, Key 2.2.4

     

     

  • timstims Posts: 2

    Well,

     

    found a solution for me:

     

    Created a synchronization code in my Android phone that was still running premium Key and then used that on the laptop version that had forgotten my subscription and settings to create the link between them.

     

    Problem solved, it seems, the passwords showing up in both devices. Source of the idea here:

    https://community.f-secure.com/t5/F-Secure-Key/F-Secure-Key-premium/m-p/68074

     

     

     

This discussion has been closed.