Wifi printer connection problem on new laptop

Hi,

 

I'm having trouble getting F-Secure to allow my new laptop to connect (set up stage) via WiFi to my Epson printer. There has not been any other security system running on this laptop.

Laptop is Win 8.1 and running F-Secure computer security premium 11.60 build 284.

 

I've looked up various solutions but none that I've found and tried have worked. The most promising was to use Settings/Network Connection/Current Firewall profile/ and change setting to "Office, Printer/File Sharing".

BUT my version does not have this! Only "Home, Office, Mobile, Block All, Allow All"

 

Any help greatly appreciated but in plain English please, I'm no whizz!

Best Answer

Comments

  • SimonSimon Posts: 2,643 Superuser
    At the risk of being corrected, I think this is probably some sort of Network configuration setting within Windows and I'm not great at that.

    If its of any use, I believe the printer has to be in the same Workgroup as the laptop, and all devices on the Network have to be in the same Workgroup to function together.

    What makes you think F-Secure is blocking it? I think you may be on a bit of a wild goose chase there, and I suggest you focus on the Network / Printer settings within Windows. What happens when you go into the Network settings and Add Printer?
  • Thanks for the reply.

     

    The reason I think that F-Secure is blocking the printer WiFi connection is that the other two resident PCs running different firewalls have no trouble connecting.

    I also tried another laptop (again not with F-Secure) that was able to set up and connect without any problem, it was from a different work group as well.

     

    I'm thinking on the lines of making an exception for the printer port within F-Secure but don't know how to do that. i.e. how to find the printer port in Win8.1 and where to place it in F-Secure.

  • SimonSimon Posts: 2,643 Superuser

    I don't think you should need to do that. I've been using F-Secure for years and have never had to make an exception to get a WiFi printer to work. F-Secure doesn't actually have it's own Firewall so any configurations would need to be done in Windows Firewall.

    I take your point that other machines without FS on them have connected without any problems.  I don't think there are any settings where you can allow specific ports, but if you open FS, go to Settings > Deepguard > Change Application Permissions, is there anything listed there in connection with the printer or Network?

    Sorry I can't be of any better help, but hopefully someone will be around later with some more qualified advice.

  • SimonSimon Posts: 2,643 Superuser
    Sorry, I didn't realise that.
  • Thanks Ben, that sounds very promising and will try this evening when back at the office.
  • Confirmed as fix.
    Nice one Ben and thanks.
This discussion has been closed.