Policy Manager 11.30, cannot add Deepguard hashes

Hello,

 

I am using Policy Server v11.30 and it is stuck attempting to insert Deepguard hash exclusions. A blank row has appeared in the list which cannot be removed. Yet if I try and distribute the policy I get an error that the SHA-1 hash must be completed. I can clear the table but the blank row remains. I've also tried exporting the list to a CSV, removing the blank row and then importing the CSV again. The blank row remains and prevents me proceeding. If I fill in the SHA-1 hash on the blank row another blank row immediately appears and I'm back to square one.

 

Here is a screenshot:

 

Deepguard_hashes.png

 

Would it help to repair the database as restarting the server makes no difference?

 

Thanks,

 

Matt

Best Answer

Comments

  • I tried running a repair of the database and it has not removed the blank Deepguard row that's giving me grief. Is there a way to manually edit the database? It is in a known format such as Sqlite?

  • Thanks Ben. You are correct, I had not checked all levels in the tree and did find a rogue blank entry. All fixed.

This discussion has been closed.