Freedome for Business problems

Hi,

 

I'm currently struggling with getting Freedome for Business installed on my iPhone 5s.

The problem is that nothing happens after I've installed the certificates and phone management, the browser opens but thats it.

The normal (home) version that I used earlier worked great and was easy to install compared to this.

Accepted Answer

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hi Johans,

     

    You mentioned certificates, do you mean that you created and took into use an Apple APN certificate?

    In order to install Freedome for Business on iOS devices you need to get Apple APNs certificate.

     

    To confirm you can always go to the PSB portal to the "Home" tab. What is the message displayed at the "Mobile devices" level?

     

     

  • Hello,

    The certificate is installed in our portal as described with the instructions we have.
    According to the instructions we have gotten, the next phase should be that the appstore should send a request for the app download but as I said, the safari browser opens and nothing happens.

  • DmitriyDmitriy Posts: 212 F-Secure Employee

    Hi,

     

    Sorry to hear that you have problems with getting Freedome for Business installed. Please elaborate on steps you carried out and what you see on the device and PSB portal. Did you get the Device Management profile installed on your iPhone? What is the device status shown in PSB portal?

     

    Normally Freedome app should be automatically pushed to your device once it becomes managed and properly registered in PSB portal.

  • The device management profile is installed sucessfully.

    Could the problem be that I earlier had the consumer version installed on the same device.

    It would be nice to get this solved asap, since it's hard to sell a product that you can't show the customer.

    freedome.JPG

  • DmitriyDmitriy Posts: 212 F-Secure Employee

    Thanks for the screenshot. Apparently, something went wrong with the mobile profile and it didn't get through. Please try to re-assign it--select the device in the portal, click Assign profile button in the operations bar and choose the current profile you have (System default profile).

  • Tried that, nothing happens.
    I've also tried to reinstall several times, but same result.
  • DmitriyDmitriy Posts: 212 F-Secure Employee

    Do you happen to have Freedome app (consumer version) installed on your device? You should remove Freedome app from the device before adding it into PSB with Freedome for Business subscription.

  • Consumer version is uninstalled.
This discussion has been closed.