Policy Manager Automatic Update Agent Not Detecting Manually Configured HTTP Proxy

I am having issues getting my Policy Manager to update definitions. The FSAUA.log states:

 

This was the last time there was a successful connection and the first failure:

 

[ 2328]Wed Nov 19 02:16:52 2014(2): Connecting to fsbwserver.f-secure.com (no BW proxy, http://10.xxx.xxx.16:3128/)...
[ 2328]Wed Nov 19 02:16:54 2014(2): Update check completed successfully. No updates are available.
[ 2328]Wed Nov 19 02:51:53 2014(2): Connecting to fsbwserver.f-secure.com (no BW proxy, no HTTP proxy)...
[ 2328]Wed Nov 19 02:52:00 2014(3): Update check failed. There was an error connecting fsbwserver.f-secure.com (Connection refused)

Log pulled today, after rebooting the server and rechecking the fsaus.cfg file and attempting to force an update through the console:

 

[ 4724]Wed Dec 03 15:55:30 2014(3):  F-Secure Automatic Update Agent for WIN32 8.36.130: Agent started
[ 4724]Wed Dec 03 15:55:46 2014(2):  Connecting to fsbwserver.f-secure.com (no BW proxy, no HTTP proxy)...
[ 4724]Wed Dec 03 15:55:48 2014(3):  Update check failed. There was an error connecting fsbwserver.f-secure.com (Connection refused)

The modified the fsaua.cfg file is as follows:

 

#TEMPLATE_HTTP_PROXIES
http_proxies=http://10.xxx.xxx.16:3128

 

I'm using Policy Manager Server 11.22.56488 running on a virtual Windows Server 2012 R2, with all current Windows updates. 

 

I can browse to the FSecure homepage at fsecure.com using the browser proxy settings. 

 

I have configured the the "Use HTTP Proxy" in Server > Settings > Automatic Updates to "From Browser Settings." There is no server address in the HTTP Proxy Address in the Console form. 

 

This is a newer installation, but the definition updates were working fine, until they didn't anymore. I'm not sure why I'm having this issue. The logs on the proxy do not show any denied packets to F Secure. 

 

I have rebooted the server. 

 

I have restarted fsaua service. 

 

Thank you for the assistance. 

Best Answer

  • JouniJouni Posts: 135 F-Secure Product Expert
    Accepted Answer

    Hello JimDiroff,

     

    If F-Secure Server Security product and Policy Manager are on the same server, they are sharing the Automatic Update Agent.

    In this case, if the HTTP proxy policy settings for that particular Server Security installation are locked via Policy Manager, then they are actually overriding the settings in fsaua.cfg file.

    In case the HTTP proxy address is locked in Policy Manager, please unlock and distribute the policy. Once the installed Server Security has the new policy setting in use, then F-Secure Automatic Update Agent should start using that http-proxy address configured in fsaua.cfg.

    JimDiroff

Comments

  • Jouni,

    Thank you for realizing that Server Security and Policy Manager were installed on the same server. Clearing and unlocking the HTTP proxy settings in Policy Manager resolved the issue.

    Thank you,

    JimDiroff
  • SedSed Posts: 1

    Hi!

    Can you please let me know how you managed to clear and unlock the HTTP proxy settings in Policy Manager?

    I'm using linux, not Windows, just in case it would make a difference!

    Thanks!

    Sed

This discussion has been closed.