Profil editor - Software Updater Exclusion

Hi,


We are currently testing portal and software functionality.
Software Updater is really interesting, unfortunately, I can't find a technical documentation (in English or in French) for managing software updater exclusions.
It seems to accept any character but I can't figure out if it work or not.
My problem is that we need to exclude updates for java due to software compatibility, typically VPN softwares and java web based management interfaces.

I Found the products supported (https://www.f-secure.com/documents/10192/406869/Software+Updater+-+Supported+Products).

What do we have to put in the exclusion list :
- Java*
- Java RuntimeEnvironment 8.0 GOLD

Does It accept wildchars ?

Thanks in advance,

 

Nicolas

Best Answer

Comments

  • DmitriyDmitriy Posts: 212

    Hi Nicolas,

     

    A rule in the SWUP exclusions table can be defined as a comma separated string with parameter-value pairs (i.e. <PARAM1>=<VALUE1>;<PARAM2>=<VALUE2>), where each parameter can be one of the followings:

    • PRODUCT - defines the name matching the software or product name (works like "contains"),
    • BULLETIN - defines the bulletin ID of software update,
    • SP - defines the service pack name,
    • PATCH - defines the patch name,
    • SEVERITY - defines the severity (0-4).

    In oder to exclude Java, you can create a rule as following:
    PRODUCT=Java

     

    Or if you want to exlude a specific version of Java, then you can add it as:
    PRODUCT=Java Runtime Environment 8.0 GOLD

     

    Hope this helps,

    Dmitriy

    LogSystem
  • Thanks a lot Dmitriy for your reply !

    We are using the psb4 portal, and I find the lack of documentation disturbing.

     

    Did I miss something or can you give me a link to a "complet" documentation ?

     

    Best Regards,


    Nicolas

This discussion has been closed.