Android version 2.1.2 crashes have a fix in the pipeline

Hello happy and disgruntled users of key! 

I would like to apologize for the annoyance and aggravation caused by some bugs in the system that slipped through our net.  I am about to push in a version which should fix many, if not most, of these issues.  If you have been experiencing crashing issues with 2.1.2 version please do post a message into this thread whether or not 2.1.3 version fixes it. 

 

If you are unsure how to check your app version, open apps, hold onto the key icon for awhile and then drag it into "app info" which appears in the header. Be careful not to drag it into uninstall. If you uninstall, you will lose your passwords and will be unable to check your version.  If you can start your key application, you can see the version by opening menu and selecting help and the version will read at the bottom. Though if you can start your application, then you probably are not suffering from the crashbug, but thats fine. 

 

If 2.1.3 version does not fix it, do post then as well so I will know to keep looking. ETA to version 2.1.3 available from play store is around coupla hours.

 

++lauri

 

Best Answer

  • Lauri_HLauri_H Posts: 59
    Accepted Answer

    And its out! version 2.1.5.  Should, yet again, fix crashbugs. Let me know if it does or does not.

     

     

    ++lauri

    Napissa

Comments

  • jpamjpam Posts: 3
    Still crash after install 2.1.3
  • Good morning!

    I see a crash report in the android developer console, and can fix that one. Sorry about this, I'll fix asap and hope to push in 2.1.4 out  today!

    ++lauri

  • Hello folks! Android key version 2.1.4 have been pushed out into play store. It might take couple of hours for it to be available, but do update and try it out. 

     

    Again, if you STILL have crashes with that version, do post a reply. Well, if you had a crash in 2.1.2 or 2.1.3 ( those that got it)  and it now works, do post a reply. 

     

     

    ++lauri

  • jpamjpam Posts: 3

    Hi,

     

    Still crashes even updated to version 2.1.4. When trying to connect another device and after entering master key password app crashes.

  • My SGS5 is still crashing after 2.1.4 update.

     

    It crashes immediately after entering the password. 

     

    Tried to reinstall and sync. Crashes immediately after giving the remote password.  Restart does not help.

     

    Error message in crash reporter is related to JSON parsing. It seems that the data it gets from my mac/iphone contains something it can't handle.

     

    Before this crashing started, I had a problem that two password were not visible on my SGS5 that were visible on my mac and Iphone. I suspect that this might have something to do with the crashes.

     

    But please, do a better job in parsing input data that just crash. Something like this completely undermines and trust on the service. If I would have used sync, I would have lost all my data.

  • Tried removing those two passwords that never synced to my SGS5. Did not help.

  • Good morning! I hope everyone had a relaxing weekend and is full of energy to face the challenges of another week. I certainly am!

     

    So, your entries are not whats causing it, I have located the culprits, I will shortly be pushing in a fix to that. I'm sorry about my engineery certainty of having corrected everything, turns out I am not all-knowing. I will see if there is some way we can make amends. 

     

    ++lauri

  • Wow, that was fast! Everything seems to be fine now. 

     

    I do hope this and other sync problems on Iphone/Android are now over. Otherwise the product is very good for the purpose.

     

    Thank you.

  • jpamjpam Posts: 3
    Works for me now, thanks.
  • Nice to hear that it works now. As a hidden bonus, try shaking your android device while in the favorites screen. If it doesn't work, you can try tapping on the text "favorites"

     

    ++lauri

  • Hi! In "my" GooglePlay (ver. 5.1.11), I cannot find any newer version than F-Secure Key 2.1.12. Any idea on how to get the newest version? I'm using a Norwegian setup. My F-Secure Key crashes ALL THE TIME, both on my phones, but also on the tablet I use. The program works fine on my computer, though.

  • Anything new here?

  • Hi! I now found the latest version, 2.2.1. It seems as if the deployment to the Norwegian Play Store just takes a little longer than to the English one. But anyway - after upgrading the problem still remains. I've sent the "crash-report" to F-Secure Support at an earlier stage, but I've got no answers on this. And it seems as if there's no answers to be received in this forum either. Pls at least reply that you have seen this problem and are concidering to look into it.

  • BenBen Posts: 2,640

    Hello Pistan,

     

    Could you try resubmitting a crash-report now that you have the latest version, so that I can forward your request to our developers?

  • Thx! The report is now sent.
  • pistanpistan Posts: 5

    Any news so far? I saw there was a new bug-fix in the app, but this did not help me out.

This discussion has been closed.