Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

New installation of PM 11.22. Jetty fails.

Installed new PM 11.22 on a freshly installed Windows Server 2008 R2. 

 

In fspms-service logfile it says over and over:

 

[INFO] Sarting Jetty...

[DEBUG] WaitForMultipleObjects returned 0

[ERROR] Jetty process (java.exe) crashed, exit code was -2

 

Offcourse PM does not work at all. PM Status Monitor says that it is not able to connect to any of the PM service ports.

 

 

Best Answer

  • JouniJouni Posts: 135 F-Secure Product Expert
    Accepted Answer

    Hello Markus,

     

    Port 8079 is already used as a Jetty stop port by Policy Manager, so basically in this case there is a port conflict with Policy Manager itself. In this case there should be some other port used for Host module.

Comments

  • BenBen Posts: 2,640

    Hello MarkusKD,

     

    This looks like a port conflict problem. Some other service is using the port configured for the Policy Manager.

     

    In order to figure out which service is using the set-up port,you can run the following command:

    netstat -anb

    For a working console, java.exe service should be running on the set-up port.

     

     

     

  • Im using ports as follows:

     

    Host module: 8079

    Admin module: 8080

    Web report: 8081

     

    Netstat -anb gives java.exe running only on port 8079, nothing on the other ports.

     

    TCP 127.0.0.1:8079 0.0.0.0:0 LISTENING
    [java.exe]

     

    There should not be any conflicting ports on the server as nothing else is installed yet.

     

    Firewall is also disabled on all 3 zones, but that should not matter as the needed ports/services are not listening...

     

  • BenBen Posts: 2,640

    Could you try to restart the F-secure services?  Apparently some are not running currently.

     

    Also what is the error you are facing when you  try to log into the Policy Manager Console?

     

    In order for our support to take a better look at the issue your are having with the Policy Manager, you could also open a support ticket, providing an fsdiag of the server.

     

  • Trying to connect to PM with Manager Console says: "Cannot connect to server. Please check that the host name and port number are correct. By default port number 8080 is assumed"

     

    Restarting F-Secure services does not start the listening processes. Now no PM ports are listening...

     

    I have a ticket opned on ID:1-XXXXXXXXXX but no one has returned my support call.

     

    EDIT: REMOVED PERSONAL DATA

  • etomcatetomcat Posts: 1,318 Superuser

    Hello,

     

    > Host module: 8079, Admin module: 8080, Web report: 8081

     

    That's a weird choice. I think 8080 is a semi-standard port number for web proxying and sometimes SSL (HTTPS) use and is best left alone.

     

    In older times, we recommended 81/8081/8082 for FSPM ports. Nowadays, some F-Secure training slideshows show 85/8085/8086 being chosen.

     

    (The factory default FSPM values of 80 for endpoint hosts, 8080 for PMC and 8081 for Web Reporting are best avoided, because IIS wants the 80/8080 ports. Some day one of your bosses will figure out, a single-purpose server running F-Secure Policy Manager could be utilized more efficiently by also making it a secondary company webserver or a backup Exchange/Sharepoint. Then you will need IIS installed and the FSPM ports will need to move, with FSAV clients practically, likely reinstalled. Such a situation is best avoided from the beginning.)

     

    Best Regards: Tamas Feher, 2F 2000, Hungary.

  • Hi Markus,

     

    Could you let us know if the issue was eventually resolved and what was the outcome? That will benefit others which might find a similar problem.

     

    Regards,

  • Yes, I changed the 8079 port to 8179 and it solved the problem. Everything works now ok.

This discussion has been closed.