Chrome and F-Secure KEY

I have not been using KEY for a while and today when I tested it will not work with Chrome version 35.0.1916.114 m and F-Secure KEY Version 1.6.139.

 

User and password fields will not take an entry from KEY. 

 

Any ideas?

Comments

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    If you not meet and mean something new (sorry if it's like that).

     

    With F-Secure Key and Chromium/Blink/Google Chrome some kind of troubles around "accessibility"-points.

    Which probably should be fix in some of new versions of Google Chrome (?!) - which probably not fixed yet.

     

    About current one situation topics:

     

    http://community.f-secure.com/t5/F-Secure-Key/Why-doesn-t-F-secure-key-work-on/m-p/47065

     

    And this one about Opera (which based on Blink-core);

     

    http://community.f-secure.com/t5/F-Secure-Key/Key-and-Opera/td-p/51711

     

    Previously... was enough to edit "chrome://accessibility" (changed to "turn on").

    But after Google Chrome 33 it's start be without "memory" for that actions.

     

    And able to launch browser with "specific keys";

    "--force-renderer-accessibility" - which can be helpful, but it's just some kind of "workaround";

     

  • UkkoUkko Posts: 2,999 Superuser

    And also... if it's not related with "known trouble".

     

    Maybe here something around Administrators-rights during launch application or 64-bit version of application.

     

    Also.. here able to get a little be "new" version  -> http://www.f-secure.com/en/web/home_global/key

  • JanneJanne Posts: 27

    The chrome://accessibility did not work few days ago, it just printed the username but not password.

     

    Now when I updated KEY Client the chrome://accessibility did the trick..

     

  • How did you "update KEY Client"?  I have the latest from F-Secure Key installed on my mac and autofill still doesn't work.  I checked the "chrome://accessibility" and it is turned on.  Still no use.

  • UkkoUkko Posts: 2,999 Superuser

    Hello,

     

    Here was about Windows-client probably.

     

    If it's same with your setting also -> http://www.f-secure.com/en/web/home_global/key

    Here able to get new one version too (it's again new one version).

     

    Maybe for Mac too (?!). And maybe with Mac-version another kind of trouble (?!).

  • ChrissyChrissy Posts: 439

    Hi Janne & KhanHannan!

     

    Haven't heard anything in this thread for a while, so just wondering if you were still having these Chrome/Key issues?

     

    // Chrissy

  • I have tried downloading the new version and then installing it, but yet no use ... I am sure it probably is just a user error at this point of time, but I don't think I can wait to figure out what my user error is.  I think I better try some other password manager.  It's a shame that I paid for the yearly subscription but there is not much happening with this product.  On my phone, I see that they removed the special character capability as well -- all the special chars that I have now is a plus, a dot and a minus sign ... is that for real?  And to top it off, the syncing stopped working.  This is just not looking good anymore.

This discussion has been closed.