PSB remote installer tool cannot see domain

Long-time standalone F-Secure user, but new to Active Directory, GPOs and the like, and I’m running into a problem seeing the workstations in order to push a new PSB install.

 

Recently we moved our network from a workgroup to one domain “ad.ourdomain.org” under one Windows Server 2008 R2 controller; very simple setup. All clients were running FSCS in standalone mode. We just upgraded to PSB 10 and thus far I have:

 

1)      Created two profiles in the Protection Service admin console

2)      Installed PSB for Servers successfully

3)      Installed PSB for Workstations successfully on my laptop

4)      PS console can see both computers and profiles are active

5)      Downloaded the uninstaller tool, PSB for Workstations exe, and the remote installer tool

6)      Uninstalled standalone FSCS from all Windows 7 machines using the FS uninstaller and rebooted

7)      Attempts to push PSB exe out to my workstations with the RIT are failing

 

The problem I’m having is the RIT cannot see my domain – ad.mydomain.org.  I tried running the RIT from my laptop as well as from the console of the Windows 2008 AD server. Same result both times – cannot see our domain. I attempted to manually type machine paths in and of course I ultimately get an error that the network path cannot be found – code 53. I am logged on to the domain with admin rights when I run the RIT. I have no other domain-browsing issues, just with the PSB installer.

  

Here is the bat file: start jre\bin\javaw -client -Dsun.awt.keepWorkingSetOnMinimize=true -cp "lib\*" com.fsecure.ritool.RITool %*

 

Could this be Sonicwall issue? In both attempts (from my laptop and the VMWare console) I am hopping over a wireless bridge. I have not yet had the chance to connect from a machine in the same physical network as the workstations – could that be the problem? I just want to eliminate anything more obvious that I might be missing first.

 

Thanks!

 

Best Answer

  • jmeanderjmeander Posts: 6
    Accepted Answer

    I just ended up pasting device names into the dialog directly rather than mess with trying to locate them. Got the job done. :)

Answers

  • chisalchisal Posts: 2

    Hello, jmeander!

     

    1) You can manually run the PSB exe installer on every machine.

     

    2) To install the PSB WKS with the Remote Installation Tool you have to:
    2.1) Run Remote Registry Service on hosts and on a machine with RIT. [to recieve proper status of installation].

    2.2) Enable NetBIOS over TCP/IP (NetBT). Local firewall must allow NetBT traffic. [to detect hosts]

    2.3) For Windows Vista and later, turn on network discovery (Control Panel > Network and Sharing Center > Change Advanced Sharing Settings).
    The following services must first be started:
    *DNS Client
    *Function Discovery Resource Publication
    *SSDP Discovery
    *UPnP Device Host

    [to detect hosts]

    2.4) the Windows Internet Name Service (WINS) infrastructure must be working properly [to detect hosts]

    2.5) Enable file sharing on computers. Local firewall must allow file sharing. [to upload installer's files to a target host]

     

    3) You can Install Policy Manager and push jar PSB WKS installer:
    http://download.f-secure.com/webclub/pm_to_psb_via-policy_guide.pdf

  • jmeanderjmeander Posts: 6

    Thank you for the very detailed reply.

     

    I had discovered Remote Registry Service and once I pushed out a GPO to enable that I was able to use the RIT by pasting in a list of host names. About half (50) of my Win7 machines successfully installed PSB and are visible in the portal; the other half are stuck at "uploading files" so I need to walk around to those and see what the issue is there.

     

    ill work on the rest of your instructions until I'm able to see the domain and report back, but thank you again.

  • FedericoFederico Posts: 38

    Hi jmeander,

     

    We would like to follow up whether the issue remains unsolved or you have managed to solve it. Please do reply to us if you need further assistance.

    Please feel free to contact us again should you need further assistance.

This discussion has been closed.