F-Secure Key doesn't work on Mac (Mavericks)

Following are the problems:


1. fn+ctrl+f2 key combination does bring up the list of entries from my key account, but clicking/entering on it does not fill out the form automatically for me. have to do manual copy/paste of password everytime i want to login to a service.


2. sync feature also does not work. The only option I see is sending installation link to app store to my own email address. no key generation!


Please advise.



  • Lauri_H
    Lauri_H Posts: 59 Former F-Secure Employee



    As of #1, I cannot say, I'll ask around.

    As of #2, Have you purchased the synch subscription from an ios or android device? If you have, you should generate a code on that device, and then enter the code on your mac. ( It won't wipe your passwords on your mac ). 



  • csjDK
    csjDK Posts: 50

    Well. This is bad news. My mac is at a repair service, so i've havne't had the time to test it on OS X. But i've had the "pleassure" on Windows XP... Ctrl+F2 doesn't work there either.

    And there is some bug or glitch with the saving or sync. Because i just changed some password using the generate feature and clicked on save, copied the password and pasted into the fill forms. And the password was changed. I then had to used them on my iPad. And... yes, they wasn't they. Only the old credentials.
    I then went back to PC, thinking it might not have sync and since F-Secure KEY stores the information locally. I would have to sync... But it hadn't saved **bleep**...


    And i've been using a password mamager for 6 years, lastpass, 1password and iCloud Keychain. I've never had any problems like before. And it's happen numerous times with F-Secure in a week or so.


    My recommendations... Don't use it. They are stuff that works. Unfornunately i released this too late.

  • Lauri_H
    Lauri_H Posts: 59 Former F-Secure Employee


    Im sorry you have had such a bad experience with out product. About your password changing flow: 


    You generated a new password, clicked on the "use this" and then clicked save? ( ie you didnt click the upper-left corner arrow to just go back to main view? since doing that doesn't save the item =( ).  That would perhaps explain why you didn't get the new password on your ipad either. I agree, there is a useability thing there that could be improved. 


    If, you are certain you clicked on the 'save' button, and not the upper-left corner, then it definately seems like a bug. Can you by any chance try to repeat this behavior? If it is repeatable, can you try to create some password entry just for testpurpose, change the password, click on save, see it hasnt changed and then send us logs? ( logs are sent by opening the 'about' from the menu, then click on the version number a few times and click "send". ( and then post here the identifying code you get from the logs ) 



  • csjDK
    csjDK Posts: 50
    I'm certain clicked save and didn't go back. Because I copied the password using the copy button, and a copy button isn't available in edit mode.
  • Lauri_H
    Lauri_H Posts: 59 Former F-Secure Employee

    Ok, I think i somehow misread earlier too, and you are right, the copy button doesn't exist in edit mode. 

    So to recap:

    1) you changed a password on PC, this worked

    2) You copypasted the new password into something and it definately was the new password

    3) You tried on another device ( IPAD) but password hadn't synched ( this could be due to network or connectivity issues on either device, or ofcourse, a bug)

    4) You went back to the PC, but the new password was lost, and the old password was there in it's place. 


    Can you look at your user & device ids in the 'about' screen on preferably both your devices and privately message them to me on this board? I can try to check up on some logs. Can you also give me some timeframe on when this happened? ( narrowing it down to a day is enough) 

This discussion has been closed.
Pricing & Product Info