FSAV ESS 11.00 fails on unmentioned VC CRT

etomcatetomcat Posts: 1,319 Superuser
Dear F-Secure Partner Support,
 
A customer installed FSAV ESS 11.00 on his servers as an upgrade. Later on, the systems started throwing the following error messages:
 
EVENT # 47480
EVENT LOG: Application
EVENT TYPE: Error
SOURCE: SideBySide
EVENT ID: 33
COMPUTERNAME: ACME-WWW
DATE / TIME: 2014.04.05. 0:31:44
MESSAGE:
"Activation context generation failed for "c:\program files (x86)\F-Secure\FSGUI\fscuif.exe". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.6195" could not be found. Please use sxstrace.exe for detailed diagnosis."
 
Why does this happen? The FSAV ESS 11.00 release note does NOT explicitly mention the necessity of Microsoft Visual C++ runtime environment. The F-Secure installer package also did not detect the lack of VC80 and did not stop the upgrade installation process.
 
This situation is not acceptable for mission critical equipment, like corporate file and messaging servers. Please release a bugfixed FSAV ESS 11.01 installation package, which has proper pre-requisites checking and also issue and updated release notes documentation!
 
We also need guidance for the affected customer, who wants to know if he needs to re-run the FSAV ESS 11.00 setup again, after installing the VC++ runtime? Furthermore, the customer needs to understand clearly if BOTH the 32-bit and 64-bit of VC++ runtime are required for installation or only the 32-bit one?
 
Thanks in advance for your urgent response,
Yours Sincerely: Tamas Feher, 2F 2000, Hungary.

Comments

  • VadVad Posts: 1,075 F-Secure Employee

    Hello Tamas,

     

    This is local GUI (fscuif.exe) related issue in ESS 11.00. It is not related to pre-requisites. Our investigations show that this issue doesn't affect security, and product functionality, as the server product is using WebUI instead of GUI.

     

    We have correct/fixed GUI binaries, and support can provide them for you now, if the situation is urgent.

    We'll also prepare a hotfix for this issue in a short time.

     

    The customer do not need to rerun the installation.

     

    Best regards,

    Vad

  • etomcatetomcat Posts: 1,319 Superuser

    Dear Vad,

     

    Thanks for the super speedy response!

     

    I will ask the customer if he needs the "bare" files urgently or can wait for the official hotfix patch?

     

    Yours Sincerely: Tamas Feher, 2F 2000, Hungary.

  • etomcatetomcat Posts: 1,319 Superuser

    Dear Vad,

     

    Is this patch included in the OpenSSL hotfix file or will it be a separate FSFIX package?

     

    Thanks in advance, Yours Sincerely: Tamas Feher.

  • VadVad Posts: 1,075 F-Secure Employee

    Hello Tamas,

     

    OpenSSL vulnerability hotfix contains only OpenSSL related binaries. The fix for VC CRT issue is not included in it.

     

    Best regards,

    Vad

This discussion has been closed.