Automatic fill-in?

Did I get this right so Key does not fill in passwords automatically based on the url like e.g. LastPass?

One has to press ctrl-f2 and choose from list?

If I got it right I am wondering how this will work in practise... having long list of passwords makes usage... not user friendly.

Key user interface is using quite lot of space for one entry so list will be long.




  • matiasmatias Posts: 9 Former F-Secure Employee



    The ctrl+f2 is meant to be the backup method where you can input your user and/or password anywhere, you can use it in native applications, web pages and with some hidden tips even in shell sessions like using Putty.


    It has a nice advantage over the clipboard since the clipboard is a shared and inherently unsecure way to enter passwords.

    Here's some hidden tip for the ctrl+f2.

    If you select from the list that opens with ctrl+f2:
        holding the shift key when you click or press enter will input only the username
        holding the ctrl key will input only the password
        holding shift + ctrl key will input username + enter + password (for console terminals)

    We've been developing the autofill feature that does it without the need for pressing the ctrl+f2 combination and we'll start beta testing it in the comming days, it differs from most passwords managers in significant ways related to improved usability and security.


    Among the exciting things it offers, you can have autofill both in native applications as well as web pages, works in web browsers and does not install itself as web browser plugin, which offers an attractive security advantage over other password managers (the surface area for attacking the application is reduced significantly in this way)

    We're very anxious to rollout the feature and we hope you'll give a try once released.



  • HannuTHannuT Posts: 10


    So there will be "full automatic fill-in" coming in near future, if got your message right. :)


    Thanks for the info, looking forward to that as the current user experience is not that motivating (ctrl-f2 I mean).



  • WaltRWaltR Posts: 3

    Well, it is Dec 26 and auto login does not work on my mac.

  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    @WaltR wrote:

    Well, it is Dec 26 and auto login does not work on my mac.


    Did you check prerequisites for Mac autofilling at:



  • WaltRWaltR Posts: 3

    First, Security & Privacy/Privacy on my Mac 10.9.1 doesn't seem to allow me to add an app, unlocked or otherwise.

    Second, Cmdl-F2 does allow me to choose a username, but not a password.


    Curiously, I have only one entry in KEY, but the username list it brings up is several long.

    So, still stuck with nothing working.

  • matiasmatias Posts: 9 Former F-Secure Employee

    >>First, Security & Privacy/Privacy on my Mac 10.9.1 doesn't seem to allow me to add an app, unlocked or otherwise.


    If i recall correctly, in latest OSX there's no obvious 'add button' (i couldn't find one myself) however i was able to add the application by drag & drop it into the list of apps, would it be possible for you to try that out?



  • JanneJanne Posts: 27

    23.1 autofill not working on any of my devices. Windows 8.1 + chrome, IE and Android tab/phone.

  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    Did you install any new software, software updates or Windows updates before you observed autofill stopped working?





  • Hi,

    what's the key in windows 8.1 when using only touch screen?

    ..there is no F2 available in windows 8.1 touch screen keyboard.



  • ChrissyChrissy Posts: 438
    Hi hoopee,

    Just to clarify, which F-Secure program are you referring to?
  • jhpjhp Posts: 2 New Member

    Product referred is F key




  • WaltRWaltR Posts: 3

    No, F2 simply doesn't work on my Mac Mavericks machine.

  • Ilpo71Ilpo71 Posts: 1

    Same here, havent got the auto filling to work on my Macbook 10.9.x or in my iPhone ?

  • jhpjhp Posts: 2 New Member

    My problem considers windows 8.1 touchscreen device. I have only virtual keyboard in use, there is no F2 - button available

  • csjDKcsjDK Posts: 50

    Help. Please help. I can't get it to work. 


    • Mac OS X 10.9 (Mavericks) and later: Go to System Preferences > Security and Privacy > Privacy tab. There is a listAllow the apps below to control your computer, you need to drag and drop the fskey executable inside that list.

    Like so? It doesn't work? fn+ctrl+F2 or ctrl+F2... 

    Skærmbillede 2014-04-25 kl. 16.39.52.png

  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    For some reason I can't see image you embedded. What type of Mac model do you have and which keyboard were you using? The physical devices and layouts. This could be a software issue or then a keyboard layout issue. But as you went already ahead and tried with the Fn-key, it can be the former.


    There are many different devices and alternate keyboard layouts who are problematic for our chosen hotkey combo. The Fn-keys who need to be used to reach certain F-keys vary a lot.


    Many of these problems seem to be Mac related. I'll take this to our designers and see if we should approach this differently.




  • NikKNikK Posts: 935 Rock Star

    unfortunately the image is only visible to the person who posted it, until it's been approved by a moderator

  • csjDKcsjDK Posts: 50

    Hi JuhaT, 


    Thanks for replying. Sorry about the image, i don’t know went wrong.


    I've got it working now – well sort of. 

    I think perhaps I'm not understanding how it works underneath the hood. And that why I get confused, and think it’s not working.


    - First of it doesn’t seem to able to enter in usernames.

    - And if I click fn+ctrl+F2. The  logo get highlighted with a blue box in the menubar so something has happened. 

    - And when i’ve entered my username. After some time (seconds, feels like a long time thought), most of the time, I see the little little blue KEY symbol appearing in the left side of the password input box. And i can click on, start tying in the name or scroll down. Sometimes nothing happens and i have to click a few times between the username and password boxes… to sort of force a reaction from KEY. As if it’s loading (or so it seems to me. But I don’t know what’s going on beneath the hood) 


    But I guess, I thought, that I could just hit and instantly fn+ctrl+F2 in the username input and choose with username & password it would fill in for me. Or at the very least, the KEY symbol should appear instantly in the password box after i’ve entered the username.


    I’m using a danish keyboard layout. But it’s not the problem. But if is like you say a problem, perhaps it could be nice if people to choose their own hotkey combination. 


    Thanks. Again JuhaT. I know there isn’t much you can do about it, at this moment.

  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    Thank you  @csjDK ! I assume the application with what you use Key in this description is a web browser. What web browser is this? Can you also figure out the current version number?


    Key does integrate with all applications on your system. However Web browsers are a bit different from any other app.



  • csjDKcsjDK Posts: 50

    Yes these issues are mostly when logining into sites via web browser.

    But as you say I also use system wide for applications (Which is awesome by the way!)


    Mac OS X 10.9.2 

    Safari Version 7.0.3

  • JapiJapi Posts: 3

    Just subcribed F-Secure Key and installed it on my all devices includin PC (W8), iPhone, iPad and iMac (Maverics 10.9.4). I followed instructions on this page which seems to be little inaccurate. Anyway I did give access to F-Secure Key app in Accessibility settings.


    Screen Shot 2014-08-27 at 18.16.02.png

    After this i rebooted my Mac and I went to some Internet page and tried to Ctrl + F2 and Fn + Ctrl + F2 key combinations for username and password fields and nothing seemed to happend. Browser was Chrome Version 36.0.1985.143.


    This worked on my PC W8

  • Hi


    Have you been able to sort out how does the autofill work in MacBookPro with OS X 10.9.4? Today I downloaded a latest version of F-Secure Key, inserted a few usernames and passwords and when trying to use my Chrome browser version 37.0.2062.94 I am not able to get the automatic fill-in to work, not with ctrl-F2 nor with fn - ctrl - F2.


    How can I get this working properly??

  • ChrissyChrissy Posts: 438
    Hi Sgtmp2014!

    Since there hasn't been any recent activity on this thread, I'm hoping you managed to get this working? Or do you still need our help? Please let us know either way!
  • JapiJapi Posts: 3

    Well I did not get answer for my question. Should automatic filling work in browser because it does not work? What shoud I do to get it work?

This discussion has been closed.