Clinet security premium - software updator

Hi

 

I run PM 11 and am in the process of testing out CSP 11 and mainly the new software updator service.

 

I cannot seem to get the updator service installed.  I have tried install CSP 11 directy onto the client but when i install it does not give me the option to tick software updator ( if this is actually an option). 

 

If i add the update to the PM 11 sever i am uable to upgrade any 9 or 10s to version 11?

 

Anyway any ideas?

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Jedflash,

     

    Please refer to the following thread.

    http://community.f-secure.com/t5/End-point/How-to-rollout-ClientSecurity-11/m-p/28944/highlight/true#M1217

     

    "Upgrade using MSI is a correct way."

     

    Also be sure to use the following correct .jar file as base.

    http://download.f-secure.com/webclub/fscspr-11.00-332-rtm.jar

     

    Thank you.

  • Hi,

     

    Thanks for you help.

     

    How can i upgarde using MSI?  is this possible to do within F-secure?

     

    Thanks

     

    Morgan

  • JaysonJayson Posts: 595

    Hi Jedflash,

    Client Security 11 Premium is a different product  than CS 9.x, CS 10.x and CS 11.x standard therefore it is not an "upgrade" scenario here, you will only get the upgrade option if you are try to upgrade CS 9.x or CS 10.x to CS 11.00 Standard edition.

    Import the jar package into PMC then export it to a MSI package. Kindly find more details for  software distributions with Policy Manager in the Admin Guide under chapter 3.4.1 Push installations and 3.4.3 Local installation and updates with pre-configured packages.

    Thanks.


    Best Regards,
    Jayson

  • Great, Thanks for this info.  Problem solved.

  • Hi,

     

    The installation worked but the software updator module did not install.

     

    I used the Push installation and when running through the setup on the server the software updator function was ticked.

     

    The installation worked and reported no errors but checking in fsecure and or contorl panel this function was not installed.

     

    Any further help would be great.

     

    Thanks

  • VadVad Posts: 1,075 F-Secure Employee

    Hello Jedflash,

     

    Please, make sure, that you are using correct Premium keycode.

     

    Best regards,

    Vad

  • Can you confirm if the code is different to version 11 standard?

     

    I enter the code and it does not complain, software update is still ticked and the installation complete without an error

     

    Thanks

  • VadVad Posts: 1,075 F-Secure Employee

    Yes, the keycodes for Standard and Premium are different. PMC can't determine if you are providing a keycode for correct product or not. It just validates the keycode, and provides a possibility to select all modules included in the package. But during the installation you will not get Software Updater module installed if you entered Standard keycode in PMC.

     

    Best regards,

    Vad

  • Thank you this makes sense.  I will get back to you when i obtain the new code from our Software team

This discussion has been closed.