PM10 upgrade - Warning: cannot open old database

stmartistmarti Posts: 29 New Member

I'v tried to upgrade from PM9 (win2k3 install) to PM10.

 

In the migration dialog I got this warning (all other steps are OK):

 

Previous installation information --> Warning: cannot open old database

 

Is this normal?

Accepted Answer

Comments

  • johan65johan65 Posts: 20 New Member

    Hi Dear!

     

     

    I have done many upgrades to my customers and according to known problem in version 9 of Policy manager and my own experiences, I used to do the following steps before an upgrade. I have to say... I also recommend you to always start an upgrade from a clean state as possible:

     

    1. PATCH the system with all 4 patches. Download here: PM9.0
    2. Remove all unnecessary and old Installation packages including version 8.
    3. Remove all unnecessary alerts and reports.
    4. Remove all unnecessary hosts in the policy-tree.
    5. Do what is told in the following article to refresh database: Se here: Error 503
    6. Take a full upgrade of PM9.0, following the information on page 65 nr:1 here: PM9.0-admin-guide
    7. Upgrade to PM10.

    I hope this will work. I have 20 upgrades until now and after doing all this steps I describe above, the whole upgrade have worked fine without any problem.

     

     

    Good Luck and my Best Regards:

    Johan O Olsson

    ATEA Sweden AB Karlstad

  • johan65johan65 Posts: 20 New Member

    Sorry. Smiley Sad I have to put my information i proper order.

     

     

    You must Patch the system after you have done the database refresh becouse it include an instalation-process of PM9.00 above PM9.00.

     

     

    Sorry for the mistake. Robot Sad

     

    My Best Regarsds

    Johan O Olsson

    ATEA Sweden AB Karlstad

  • stmartistmarti Posts: 29 New Member

    I have all the patch, and I have still a win2k client (version 8). All hosts are up to date, no error 503 problem.

     

    Anyway I think is better to uninstall pm and make a clean pm 10 install.

    This way how can we reconnect an existing centrally managed client to the new pm 10 install?

     

    thank you

     

  • johan65johan65 Posts: 20 New Member

    Hi Dear!

     

     

    According to the 503-problem. What I mean is not that you have a 503-problem. What I mean is to refresh the database.

    According to version 8 and older. This version will not be supported after the 31 of December this year, wish means that you will not receive any more virus-definition-update, patches or any other support. It is really important for you to upgrade to version 9 including all patches to have a secure and fully supported system. Please. Read more here: End of Support.

     

     

    Best Regards:

    Johan O Olsson
    ATEA Sweden AB Karlstad

  • stmartistmarti Posts: 29 New Member

    Mathias,

     

    Thank you for the confirmation!

This discussion has been closed.