Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

F-Secure publishes hotfix on proprietary update validation mechanism

F-Secure's proprietary update validation mechanism will expire and hotfixes are required to ensure that affected products continue receiving updates after Monday, May 27th 2013. Installation of the hotfixes are mandatory to ensure that products receive and install new incoming updates and continue working normally in the following scenarios.

Impact: Affected products that are installed AFTER the old signing mechanism has expired will be unable to validate and install some or all updates downloaded from F-Secure.

The affected product versions are:

Note: Affected products that were installed and receiving updates PRIOR to the expiration date will continue to work normally without user action.

 

Note: Protection Service for Business 9.x hotfix is delivered through channel update and should not require further activities from the user. Other products require an administrator to apply the hotfix.

 

Note: Restart is not required after installing this hotfix.

 

More details from Support News.

Comments

  • Lauri_BBLauri_BB Posts: 2

    Hello,

     

    Do I understand this correctly, for example:

     

    If we have Client Security 9.31 and 9.32 installed before May 27th 2013, then no action will be necessary for those machines, they will continue working fine?

     

    if we install CS 9.31 or 9.32 after May 27th 2013, then we will also need to apply the hotfix for the updates to work properly?

     

     

    Best Regards,

    Lauri

  • BenBen Posts: 2,640
    Accepted Answer

    Hello Lauri_BB,

     

     

    The hotfix should only be necessary for NEW installations of the windows products after the specific proprietary update validation mechanism has expired. (after May 27th )

     

    Existing setups and installations prior to that day should have already received the necessary engine updates over the automatic updates to continue working fine & without incident.

     

    Cheers.

    Lauri_BB
  • copekacopeka Posts: 5

    Hot Fix states that it can be applied to versions 9.10 - 9.31.

     

    So when installing cs 9.32 there is no need to install that hot fix?

     

     

  • Sam77Sam77 Posts: 3

    Just called F-secure support to confirm and according to them the hotfix can be used to version 9.32 as well.

    Chrissy
  • copekacopeka Posts: 5

    But is it needed for  new installed 9.32 clients to work properly?

     

     

  • VadVad Posts: 1,048

    Hello copeka,

     

    Hotfix is applied to versions 9.10 - 9.31 of F-Secure Anti-Virus module, which is not directly related with product version.

    The hotfix is needed for all new installed 9.x versions of corporate products. Note that for PSB products it comes automatically from the portal.

     

    Best regards,

    Vad

  • etomcatetomcat Posts: 1,317

    Dear Vad,

     

    In the partners-only forum section I made a very damning comment about this hotfix issue yesterday but haven't received a reply. I must demand an urgent response to that entry!

     

    Best regards, Tamas Feher, Hungary.

  • VadVad Posts: 1,048

    Hello Tamas,

     

    I'm not sure what forum are you talking about.

    Could you, please, share the link to your comment?

     

    Thanks in advance,

    Vad

  • etomcatetomcat Posts: 1,317

    Hello,

     

    > I'm not sure what forum are you talking about.

    > Could you, please, share the link to your comment?

     

    I am talking about this one:

     

    http://community.f-secure.com/t5/Exclusively-for/Hotfix-totally-unacceptable/m-p/26440#M129

     

    or F-Secure Partner Support SR ID: 1-565461191.

     

    Sincerely: Tamas Feher, Hungary.

  • etomcatetomcat Posts: 1,317

    Hello,

     

    What is the situation with the FSAV ESS 9.20.682 RTM build? (The F-Secure File and Terminal Services Security 9.20 and the F-Secure E-mail and Server Security 9.20 products)?

     

    Are they affected by the problem? The knowledge base article fails to mention them either as affected or non-affected products:

    www.f-secure.com/en/web/business_global/support/support-news/view/story/943281

     

    Thanks in advance, Sincerely: Tamas Feher, 2F 2000, Hungary.

  • VadVad Posts: 1,048

    This products are affected.

     

    Best regards,

    Vad

This discussion has been closed.