folder re-directs

   I have a SBS 2008 server that I have installed Email and Server security on. We have also installed FSecure Client Security on the workstations. I started a scan on the workstations and noticed the CPU high on the server. It occurred to me that we have folder re-direction setup on the workstations and that the client scan was actually scanning the folders on the server due to the re-direction. It seems to me that this would cause a lots of problems if the client and the server were both scanning the same files at the same time. How do I keep the clients from scanning the re-directed folders? I found the exclusion list, but I'm not sure what path to put in.


  • jackmajackma Posts: 57

    Hi OGlam,


    since the folders are on the server, performance wise it makes sense to only scan there. So excluding on the client is the way to go, so that scanning via network does not slow anything down.


    You will have one caveat though. DeepGuard will also obey the exclusions on the client side. Which means that during execution of an executable, DeepGuard will not protect the client.


    If you decide, you need the extra security (nothing wrong with that) then all that is happening is that the clients and the server scan data twice, but the resources are distributed between the server and the client. The load is not "double" if you think of the system itself. Conceptually, yes there is a double scan.


    We cannot answer your questions, which folders to exclude, if you chose that way. We just do not know what you have re-directed. That is something you have to tell us.


    All I found is this:


    Let us keep the debate open to the rest of the community.



  • OGIamOGIam Posts: 5

    I'm not so much concerned with resources as with possible file corruption from 2 disconnected processes accessing the same file. We are only re-directing the desktop and My Documents folders. I added the following to excluded objects. Do I need quotes for the spaces in the directories?


    C:\Documents and Settings\*\Desktop\*
    C:\Documents and Settings\*\My Documents\*
    C:\Users\*\My Documents\*

  • jackmajackma Posts: 57

    Hello OGlam,


    please refer to following


    Depending if excluding with wildcards, you have a different syntax in Realtime or OnDemand scanning.




    EDIT: updated URL

  • OGIamOGIam Posts: 5
    Thanks for the link. I corrected my excluded to: Object *\\HarddiskVolume1\\Documents and Settings\\*\My Documents\\* *\\HarddiskVolume1\\Documents and Settings\\*\\Desktop\\* *\\HarddiskVolume1\\Users\\*\\Desktop\\* *\\HarddiskVolume1\\Users\\*\\My Documents\\*
This discussion has been closed.