FSPM10 and RHEL6

I'm trying to install the Policy Manager Server 10.01 on a RHEL 6, but there seems to be something odd in the scripts.

 

 $ sudo rpm -i f-secure-policy-manager-server-10.01.40788-1.x86_64.rpm

ERROR: Your system has no suitable libstdc++ library

(libstdc++.so.5 is required)!

If you are running Red Hat Enterprise Linux 4 or 5 please make sure that you have

'compat-libstdc++-33' package installed.

error: %pre(f-secure-policy-manager-server-10.01.40788-1.x86_64)-script failed, status 1

error: install: %pre-script failed (2), skipping f-secure-policy-manager-server-10.01.40788-1 

 

I even installed the compat-libstdc++-33 -package, but even so I get this error. The only documentation I find about this is the one mentioned in the output. I can't seem to find anyone have issues with this in RHEL6. 

 

I'm going to go through the scripts now in order to see if I can locate where libstdc++.so.5 should be. (Symlinking it in /lib/ didn't help.)

 

If you have any tips and tricks regarding this, please do share. =)

Accepted Answers

Comments

  • Found it. This is not where libstdc++.so.5 ends up on a 64bit RHEL6 system. This should probably be fixed in the RPM file.

     

     

    if [ ! -e /usr/lib/libstdc++.so.5 ]; then
            echo "ERROR: Your system has no suitable libstdc++ library"
            echo "       (libstdc++.so.5 is required)!"
            echo "       If you are running Red Hat Enterprise Linux 4 or 5 please make sure that you have"
            echo "       'compat-libstdc++-33' package installed."
            exit 1
    fi

     

  • Roger that. I'll give that a try!

  • Yes! This worked for me! Thanks!

  • Rama1Rama1 Posts: 2

    I have same issue, I can't even intall the compat-libstdc++ , I am using rhel6 64 bit

     

     

    [[email protected] lib]# yum install /home/seth/Downloads/compat-libstdc++-33.i686.rpm
    Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
    Updating certificate-based repositories.
    Unable to read consumer identity
    Setting up Install Process
    Examining /home/seth/Downloads/compat-libstdc++-33.i686.rpm: compat-libstdc++-33-3.2.3-69.el6.i686
    Marking /home/seth/Downloads/compat-libstdc++-33.i686.rpm to be installed
    Resolving Dependencies
    --> Running transaction check
    ---> Package compat-libstdc++-33.i686 0:3.2.3-69.el6 will be installed
    --> Processing Dependency: libgcc_s.so.1 for package: compat-libstdc++-33-3.2.3-69.el6.i686
    --> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: compat-libstdc++-33-3.2.3-69.el6.i686
    --> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: compat-libstdc++-33-3.2.3-69.el6.i686
    --> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: compat-libstdc++-33-3.2.3-69.el6.i686
    --> Finished Dependency Resolution
    Error: Package: compat-libstdc++-33-3.2.3-69.el6.i686 (/compat-libstdc++-33.i686)
               Requires: libgcc_s.so.1(GCC_3.3)
    Error: Package: compat-libstdc++-33-3.2.3-69.el6.i686 (/compat-libstdc++-33.i686)
               Requires: libgcc_s.so.1(GLIBC_2.0)
    Error: Package: compat-libstdc++-33-3.2.3-69.el6.i686 (/compat-libstdc++-33.i686)
               Requires: libgcc_s.so.1(GCC_3.0)
    Error: Package: compat-libstdc++-33-3.2.3-69.el6.i686 (/compat-libstdc++-33.i686)
               Requires: libgcc_s.so.1
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

  • etomcatetomcat Posts: 1,319 Superuser

    Hello,

     

    When will we have FSPM 11 for the Penguin?

     

    Thanks in advance, Sincerely: Tamas Feher, 2F2000, Hungary.

  • ChrissyChrissy Posts: 438

    Hi Sethu, thanks for posting the update to your issue!  Let us know if you have any more trouble :)

     

    // Chrissy

This discussion has been closed.