Server Security 9.20 Failing to Update

I'm having an issue with a 2008 R2 server which since upgrading it to v9.2, fails to update.

 

I removed v9.0, restared and installed v9.2.  Since, it downloaded but wouldn't install all the modules.

 

I then ran the FSAUAReset Tool, which reports the wrong version installed (v8.0 - the tool needs updating) and since it has downloaded the ORSP engine module, installed it but no other modules have been downloaded or installed.

 

The log has the following inside; Update check completed successfully. No updates are available.  The Systray icon shows a yellow exclamation which means the defs are outdated!

 

I sent an FSDiag to tech support yesterday evening but haven't heard back yet.  To be honest, they can be really slow sometimes and we're meant to have Silver Support!

 

Anyone having the problem?  Anyone help with this?

Best Answer

Comments

  • Why not update it from 9.0 to 9.2 without removing the 9.0 version? image

  • VadVad Posts: 1,062 F-Secure Employee

    Hello Rick586,

     

    Please, try to restart FSMA and FSGKHS services, or simply reboot the server if possible.

    Sorry, I can't say more without fsdiag logs.

     

    BTW, what version/build of FSAUAReset tool do you have? 8.25 build 3692 should work.

     

    Regards,

    Vad

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    if you have submitted a Support-case, then either wait for a reply and if needed escalate by phone-call.

    In any case (also wehn askimng here) you should have the SR-ID posted, so that the team can look into the case.

     

    BR

  • Rick586Rick586 Posts: 53

    Tetrapackage;

     

    Because version 9.0 was causing an issue on that server and in my experience, trying to upgrade a system which has problems, in the hope of resolving the problem, is an exercise in futility!

     

    As I was having problems with this installation, the removal and install plus a flush of the file system and registry seemed a cleaner way to get 9.2 installed and this tactic has work for me on many occasion but even after all this, on this occasion it didn't work. Smiley Frustrated

     

    Hello Vad; I've tried all that and the reset tool I downloaded, I assume is the latest version as I got that off your support FTP site.

     

    Support Call ID: [SR ID:1-514336449] Server not updating

  • Rick586Rick586 Posts: 53

    I'm still suffering with this issue.  Even applying the manual update, it didn't work! Smiley Mad

     

    I think there may be a bug with v9.2 and I've now submitted at least 3 FSDiags.

     

    I wouldn't mind intervention by third-line or the developers on this issue as it's been ongoing for over a week and I'm about to rollback to v9 as I can' t really leave this server running on a live network with faulty AV software.

     

    The SR-ID is posted above.

     

    Thanks in advance for any help.

  • VadVad Posts: 1,062 F-Secure Employee

    Hello Rick586,

     

    Fsdiag from your server shows Windows 2008 R2 Datacenter edition OS, which is not supported by SS 9.20.

    You can find this information in ESS 9.20 release notes.

     

    Regards,

    Vad

  • Rick586Rick586 Posts: 53

    Hello Vad.

     

    Thank you very much for this information and you are indeed correct, it is running DataCentre edition.

     

    When I checked for the supported OSs, I saw Microsoft® Windows Server 2008 R2 listed and probably skipped the rest of that section!

     

    Is there a reason why it doesn't support the DC edition?

     

    To be fair to me, I'd now sent several FSdiags to your first-line support team and no one had spotted that either and over a week later, probably two weeks since I opened this support call!!!

     

    In that case, I expect I'll have to revert back to v9.0?  Shame, as v9.2 looked a much better version...

  • Rick586Rick586 Posts: 53

    Hi Vad.

     

    Are you suggesting that I may be able to get this version to work under DC even though it states that SS isn't supported on this edition?

  • VadVad Posts: 1,062 F-Secure Employee

    It is possible, that the issue you have is not directly connected with your OS. We didn't test SS 9.20 on Datacenter OS at all, so I can't say anything for sure.

    If you think that version 9.20 is much better for you, then the only thing I can recommend - to try clean installation once again.

     

    Best regards,

    Vad

  • DmitriyDmitriy Posts: 212

    Hi,

     

    I also think that the problem has nothing to do with Windows DataCenter edition. Please let us know if clean reinstall will help.

     

    I'd like to note that neither FSAV for Windows Servers 9.0 nor Server Security 9.20 supports this edition, which Microsoft provides as a platform for really large-scale workloads and mission critical applications. It was not clearly stated in the release notes of FSAV for Windows Servers product, but Server Security 9.20 release notes hopefully clears this up.

  • Rick586Rick586 Posts: 53

    Vad, Dmitriy.

     

    I'm just doing a removal of SS9.2 now using Add/Remove Software followed by a rebbot.  Then, I'll delete all the program folders, followed by a cleanup in the Registry.

     

    One thing occurs to me and that is why there isn't a 64-bit version, especially as R2 for servers is now only available in 64-bit?

     

    It's likely that Windows 8 will be 64-bit only too!

  • Rick586Rick586 Posts: 53

    Good news as the re-install has worked!

     

    Just to be sure, after the reboot and manual removal, I ran the removal tool just in case I had forgotten to remove something out of the Regsitry.

     

    All the modules have been downloaded and installed so it looks like that SS9.2 does work with DC edition.

     

    For the record, I also installed Deep Guard as this has particular value on a server and was one of the things I was interested in deploying on our server farm, espeically on servers which have confidential data.

     

    Lastly, you may also be interested to know that this server is running in an MS Hyper-V environment.

  • DmitriyDmitriy Posts: 212

    Good to know that reinstall helped to solve the problem. We will anyway check fsdiag reports you sent and try to find a root cause.

     

    The fact that the product works ok on your environment doesn't mean that Windows Data Center edition is officially supported. In order to claim Windows Data Center support, we have to conduct proper QA tests on hardware configuration with up to 64 CPUs and 2 TB RAM, which what this platform is designed for.

    Rick586
  • Rick586Rick586 Posts: 53

    Thank you Dmitriy.  I would be interested to know what the root cause was.

     

    I'm happy to report that all is still operating well this morning so no change over night!

     

    The only reason we deployed DC edition to some servers was because we could!  Our MS Enterprise Agreement currently allows us to do so and certain servers may need lots of RAM or processing power in the future.  As this server is a virtual, we can change CPU and RAM quite quickly and the DB on this machine will grow quite large over time as it's core to our business.  It also has a web portal and GUI for the users where they can run reports, query information, run calculations, etc, so it has to deal with quite heavy workloads at certain times of the day and month.

     

    It's unlikely that we'll allocate 64 CPUs or 2TB RAM though... Smiley Wink

     

    Many thanks.

  • keioozkeiooz Posts: 41

    Is it possible to remove this program via Add/Remove function of Windows via CP? image

This discussion has been closed.