Browsing protection breaks some Google results on Safari

jjaine
jjaine Posts: 3 New Member

When using the Browsing protection extension on Safari, some Google results are missing parts of the URL and page title.


Accepted Answer

  • ArthurVal
    ArthurVal Posts: 168 F-Secure Employee
    edited July 6 Answer ✓

    @jjaine

    Verified from our side. I can reproduce the issue with the same version of CP&RDR product.

    And indeed SAFE Mac 18.2 release is not affected due to it having slightly more fresh JavaScript logic which is more compatible with the latest Google layout.

    Discussed the release plans with the team responsible for CP&RDR release. As far as I understood, the plan is to release an update for CP&RDR by the end of summer. But there is a chance this might happen earlier. This update should include the improvements to our JS code.

    You should be able to monitor for updates on https://community.withsecure.com.

    And I would suggest to report bugs found with CP&RDR and other B2B products on that Community site. There is a better chance that it will reach the responsible team faster.

    Best regards, Arthur

    Mac R&D Team

    jjaineFirmy

Answers

  • ArthurVal
    ArthurVal Posts: 168 F-Secure Employee

    Hello, @jjaine!

    Thanks for reporting the issue. Could you please share which version of SAFE product you currently have installed?

    You should see the version by clicking on the product icon in the menubar area. Thanks!

    Best regards, Arthur

    Mac R&D Team

    JaimsFirmy
  • jjaine
    jjaine Posts: 3 New Member

    I'm actually using F-Secure CP and RDR, Version 22.2 (44008) but did not find a place to report bugs relating to that product. The Browsing Protection extension has the version 3.0.44008 and I'm using Safari Version 15.5 (17613.2.7.1.8) on macOS Monterey, Version 12.4 (21F79). Hope this helps!

    ArthurVal
  • ArthurVal
    ArthurVal Posts: 168 F-Secure Employee

    Thanks! Yeah, that helps localize the issue. I have verified the issue with SAFE 18.2 and could not reproduce the issue with it on my machines.

    Will try to check with CP of that version. I suspect that it has an older codebase without latest changes released to SAFE. Will report back once I have more information.

    Best regards, Arthur

    Mac R&D Team

    jjaineJaimsFirmy
  • jjaine
    jjaine Posts: 3 New Member

    Thanks, I'll wait for the update then!

  • Jaims
    Jaims Posts: 860 Former F-Secure Employee

    Hi @jjaine

    Thank you for reaching F-Secure Consumer Community.

    As mentioned by @ArthurVal it will be better to also raise this issue on the WithSecure Community site to attract the relevant attention, perhaps including the link to this conversation might also help so you do not have to make a new long explanation.

    Please make use of this new Community page for Business users in your subsequent posts.

    Thank you.

    Firmy