Push Install of Server Security 15.30 stuck at "Installation in Progress..."

aimutch
aimutch Posts: 28 New Member

On multiple servers, I've had the push install of Server Security get stuck at the "Installation in Progress..." step of the dialog that pop-ups on the desktop when the installation is running. In every case, the version of the .NET Framework installed on the server is less than the required 4.7.2. Is there some logic in the installer that is getting stuck on this?

The reason I ask is that if I run a standalone MSI of 15.30, it pauses the installation if the required version of .NET Framework is not installed and I have to manually acknowledge that message before proceeding. Is the remote installer doing the same and getting stuck?


Answers

  • aimutch
    aimutch Posts: 28 New Member

    Here is the dialog you see if you try to run the MSI installer at the console versus doing a remote push.


  • Jamesch
    Jamesch Posts: 352 Moderator

    Hi,

    Did you try to install .NET 4.7.2 before starting the installation ?

    Jaims
  • aimutch
    aimutch Posts: 28 New Member

    No. I realize that it's a prerequisite for certain elements of the 15.30 version of Server Security. However, it seems the remote installer shouldn't just hang endlessly if it's getting stuck because that's not installed (I'm assuming that's the case, I don't know that it is).

  • Jamesch
    Jamesch Posts: 352 Moderator

    Hi,

    Now the simple solution is to install required .Net version. As far as I remember, there should be a timeout for installation time, after which it should fail , within 30 minutes.

    Jaims
  • aimutch
    aimutch Posts: 28 New Member

    If there's a time-out built in, I didn't see it. I found a couple servers still showing the install dialog at the console hours after the installation had started.

  • Vad
    Vad Posts: 1,089 F-Secure Employee

    Hello!


    If possible, please, provide diagnostic information from such host(s) to our support for investigation.


    Best regards,

    Vad

    Jaims
  • Sethu
    Sethu Posts: 723 F-Secure Employee

    Hi @aimutch

    Are you still facing the same issue? if yes, our RnD has now created a fixed installer that should bypass the product installation requirement. You can reach our F-Secure Support to get the hotfix.

    Jaims