Security Cloud is unavailable

From time to time, I get this notification about Security Cloud not being available. There are however no warnings in the web-based administration console, and the notification doesn’t appear on all Macs at the same time, not even on all Macs connected to the same local network. Is anyone else experiencing the same issue? 

• macOS Big Sur 11.5.1

• F-Secure Computer Protection 21.2 (38681)

Accepted Answer

  • jameschjamesch Posts: 284 Moderator
    Accepted Answer

    Hi,

    Checked with our developer. With this build, we have Ultralight and Security Cloud, and it is broken. Ultralight team is working on fixing it. Once the fix is available, we will release a new build and push it to channels.

    karlemilnikka

Answers

  • jameschjamesch Posts: 284 Moderator

    Hi,

    Normally, you may get this kind of error message after the product installation when there is a communication issue to the Security Cloud backend.

     

    If your Mac machine is behind the firewall, make sure that the connection to the following domains are allowed.

     

    *.f-secure.com

    *.fsapi.com

     

    You could run the following commands in Terminal to check if the connection to the Security Cloud backend can be done successfully or not.

     

    ping orsp.f-secure.com

    nslookup orsp.f-secure.com

    curl -v http://orsp.f-secure.com/getcrl0 > /dev/null

     

    If the connection is working fine, perform the solutions in the article below and check if there is any improvement.

     

    https://community.f-secure.com/common-business-en/kb/articles/5802-realtime-scanning-is-not-enabled-on-high-sierra-or-mojave-mac-computer 

     

    If the issue still persists after performing the suggested steps above, it may be related to a corrupt "hosts" file on the Mac.


    First, you can try to restart your Mac computer. If the issue still present, follow the steps below to reset the hosts file on the Mac:


    Steps:


    1. From the Finder, navigate to Go → Go to Folder

    2. Type this in the Go to Folder window: /private/etc/hosts

    3. From the finder window, click and drag the hosts file to the desktop. (we're doing this because we can't open the hosts file directly and edit it)

    4. Double-click the hosts file (on the desktop) and it will open in TextEdit (or any default text editor on your Mac)

    5. Erase everything in it.

    6. Copy the following piece of text and paste it into the hosts file


    ##

    # Host Database

    #

    #

    # localhost is used to configure the lookback interface

    # when the system is booting. Do not change this entry.

    ##

    127.0.0.1     localhost

    255.255.255.255   broadcasthost



    ::1        localhost

    fe80::1%lo0   localhost


    7. Save this file

    8. Open Go to Folder window

    9. Open /private/etc/hosts again

    10. Drag the hosts file on desktop back to the /etc/ folder. You will be asked about the existing hosts file

    11. Choose Replace and authenticate with the admin password when asked for it


    Note:

    As we don't rely on hosts file anymore in currently available versions, a re-installation of the F-Secure product on your Mac computer should also solve the issue. 


    Apart from that, there is also a possibility that it is caused by a cleaning application (for example, MacCleaner Pro, App Cleaner or etc) that disables the third party services to improve the performance.


    In order to solve this, you may consider to implement the following steps.


    1. Remove F-Secure product if it is currently installed.


    2. Open Terminal app. It is located in "Applications" default macOS directory.

        It has a subdirectory called "Utilities". Terminal app is located there.


    3. Execute all the commands below one by one.

        Enter an administrator's password if it is asked by the Terminal app.


        sudo launchctl enable system/com.f-secure.fscsafeadmind

        sudo launchctl enable system/com.f-secure.fsmac.fsupdated_guts2

        sudo launchctl enable system/com.f-secure.fsmac.guts2downloader

        sudo launchctl enable system/com.f-secure.orspclient

        sudo launchctl enable system/com.f-secure.fscsafesettingsd

        sudo launchctl enable system/com.f-secure.fsmac.licensetool

        sudo launchctl enable system/com.f-secure.fsctelemetryd

        sudo launchctl enable system/com.f-secure.fsavd.dbhelper


    4. Install F-Secure product again.

  • karlemilnikkakarlemilnikka Posts: 13 New Member

    Thanks for the detailed instructions. I’ll try it out.


    Best regards

    Karl Emil Nikka

  • karlemilnikkakarlemilnikka Posts: 13 New Member

    To keep good forum practice, I’d just like to add that I didn’t get a chance to test these suggestions. The warning had disappeared by itself before I had time to investigate it. I’ll update this post the next time I get the warning.  

    Best regards

    Karl Emil Nikka

  • karlemilnikkakarlemilnikka Posts: 13 New Member

    Here’s a quick update. There are no problems connecting to the domains and the hosts files are in order. I haven’t gone through the reinstallation process since I ran into the very same issue on a fresh-installed VM I setup for test-purposes.

    One common factor for all involved Macs is that the users aren’t signed in on accounts with admin privileges when the warning pops up.

  • karlemilnikkakarlemilnikka Posts: 13 New Member

    Hi @jamesch. Thanks for the info. I'll just wait for the new release then.

Sign In or Register to comment.