Blank F-Secure Email and Server Security 15 Web Console after upgrading from 12 version

jdy102jdy102 Posts: 2 New Member

Hi,

I've upgraded our installation (v12) to 15 version. After completing setup - web console is shown totally blank (checked in IE and Firefox) - without any error (except cert notification). During initial setup after installation, I set F-Secure to use server cert, but now I've created self-signed cert (Login to F-Secure Email and Server Security 14.x/15.x Web Console not working, page not displayed - F-Secure Community (f-secure.com)).

I cannot assign F-S created cert in IIS console as after changing to it I'm getting error

I've created self-signed cert directly in IIS than I can assign it to F-Secure site, but web console still is showing blank.

All F-Secure services are running.

OS : WinSrv 2k16 Std

How can gain access to Web Console ?

Accepted Answer

Answers

  • jameschjamesch Posts: 290 Moderator

    Hi,

    Do ensure that you are not using old link such as - 127.0.0.1:25023/index.php

    We had one customer who saved links from old ess12 webui and tried to access them after upgrade.

    Basically webui needs following to work:

    1) Running iis

    2) Running site with cert in iis

    3) Running app pools in iis

    4) Browser run under admin user

  • jdy102jdy102 Posts: 2 New Member

    I'm using the new Web console link --> https://127.0.0.1:25023

    IIS and app pools are running

    Cert is assigned (self-signed, generated in IIS)

    Browser (IE) is started as administrator.

  • jameschjamesch Posts: 290 Moderator

    Hi,

    Have you tried other browsers?

    We have seen webui was working in Firefox but displayed blank page in IE

    Vad
  • KrzysztofBKrzysztofB Posts: 3 New Member

    Hello,

    I have the same problem. I have tried IE, EDGE and Firefox.

  • jameschjamesch Posts: 290 Moderator
    edited June 8

    Hi, can you try to disable UAC and use Chrome ?

  • KrzysztofBKrzysztofB Posts: 3 New Member

    Hello,

    I disabled UAC and tried Chrome, FF, IE. Web console still display blank page.

  • MonikaLMonikaL Posts: 182 Moderator

    Hi,

    This is most likely a CERT issue. 

    We will suggest to check on the following 2 KB articles.


    https://techcommunity.microsoft.com/t5/iis-support-blog/error-hresult-0x80070520-when-adding-ssl-binding-in-iis/ba-p/377281

    https://support.oneidentity.com/de-de/kb/213461/error-hresult-0x80070520-when-adding-ssl-binding-in-iis


    Also From IIS cert bindings, for Email and Server Security (ESS), remove any extra entries if listed and make sure only the loopback IP address is listed. 

    Once done re-run the setup, that is by executing the application file: F-Secure.Ess.Config located under C:\Program Files (x86)\F-Secure\Email and Server Security\ui and during the setup you can select the CERT. 

    You can also use the Self Sing Cert for Web console, while use the ESS Config tool, its on step 7.

  • KrzysztofBKrzysztofB Posts: 3 New Member

    Hello,

    I installed additional features in IIS (Default Document, Directory Browsing, HTTP Errors, Static Content, HTTP Redirection, HTTP Logging, Custom Logging, Request Monitor, Tracing, Request Filtering, Basic Authentication, Client Certificate Mapping Authentication, Digest Authentication, IP and Domains Restrictions, Windows Authentication, .NET Extensibility 4.5, ASP .NET 4.5, ISAPI Extensions, ISAPI Filters, IIS Management Console, IIS 6 Metabase Compatibility, IIS 6 Management Console) and it help.

    Thank you

Sign In or Register to comment.