Error Assertion failed since last update March 2021

ErikGeurtjensErikGeurtjens Posts: 7 New Member

Hi,

Hello,

I have been using Fsecure Key for several years without any problems (via XS4all). Since the last update of 1,5 week ago I get a C++ error. 

I am using Fsecure Key on a windows 10 machine (64 bits). 

Windows is fully updated. 

I have uninstalled F secure Key, and reinstalled it. This has no effect. Same error

Does anyone have a solution ?



Accepted Answer

  • CaleCale Posts: 113 F-Secure Product Manager
    Accepted Answer

    Hi,

    We were not able reproduce the issue, but we identified a possible cause for the assertion message and included a fix in the next version that is scheduled to be released at the end of April. Sorry for the trouble you have gone through.

    -Cale

    ErikGeurtjensLakshJaimsUkko

Answers

  • LucaseuropaLucaseuropa Posts: 254 Moderator

    Dear @ErikGeurtjens


    Thank you very much for your question.

    Please note that F-Secure KEY via XS4ALL is a modified version of our program offer for XS4ALL customers.

    You might, however, try to completely remove this app using our tools first (just bear in mind that it can also remove SAFE by XS4ALL from your computer).

    1. Download the Uninstallation Tool for Windows from our Support Tools page.
    2. Run the executable FsUninstallationTool.exe. The User Account Controls appears.
    3. Click Yes.
    4. Click Start.
    5. Select "F-Secure KEY" and click Next to initiate the uninstallation process.
    6. Click Restart when prompted. This is to remove remaining files.
    7. After the restart, reinstall KEY from XS4ALL website.


    Also, by removing the app using the UI tools, you'll also get rid of the data that is stored on your computer, so please either make a backup of your passwords by exporting them or make sure that you have synchronized KEY on your Windows with KEY app i.e. on a mobile device.

    Cheers,

    Lucas

  • ErikGeurtjensErikGeurtjens Posts: 7 New Member

    Hi Lucas,

    Thanks for the quick response.

    Unfortunately it didn't work. Same error.

    kr

    erik

  • kimmokotanenkimmokotanen Posts: 2 New Member

    Hello,

    I have same error. (F-secure ID-protection)

    Uninstallation tools and reinstall not works.

    Install C++ 2012 visual studio C++ Redistributable x86 and x64, not help.


    br, Kimmo Kotanen



  • ErikGeurtjensErikGeurtjens Posts: 7 New Member

    To make sure the error was not caused by another program, today I formatted my hard drive, reinstalled windows 10, The first thing I did was installing Fsecure key . Unfortunately, still the same error. Also the original version F-secure ID protection gives exactly the same error.


    Dear F-secure : do you have a solution? So, with high probability, it's your program that's to blame !!! 

  • LucaseuropaLucaseuropa Posts: 254 Moderator

    Dear @ErikGeurtjens and @kimmokotanen ,


    This issue is currently being investigated by my colleagues from the technical department, should we got more information or any update on that, I will let you guys know by posting here.

    Thank you for your input and for your understanding.

    Cheers,

    Lucas

    Jaims
  • ErikGeurtjensErikGeurtjens Posts: 7 New Member

    Thanks for the effort !

  • LucaseuropaLucaseuropa Posts: 254 Moderator

    Dear @ErikGeurtjens and @kimmokotanen ,


    I would like to ask you for more detailed information from your computers in order to pass it forward to my colleagues who are currently investigating this issue.

    Thank you for your cooperation in solving this issue.

    Cheers,

    Lucas

    Laksh
  • ErikGeurtjensErikGeurtjens Posts: 7 New Member

    Hi Lucas,

    Do you have an update for me ?


    kr

    Erik Geurtjens

  • LucaseuropaLucaseuropa Posts: 254 Moderator

    Dear @ErikGeurtjens,


    It should be fixed in 5.1 release (version 5.2.2321). The latest product version is 5.2.2324, please check which version of the program you are using first and confirm whether you still experience the issue or not.

    Thanks!

    Cheers,

    Lucas

  • ErikGeurtjensErikGeurtjens Posts: 7 New Member

    Hi Lucas,

    I'm using the latest version 5.2.2324.0/Key.

    The previous version worked perfectly. The problems started after the last update in mid-March. 

    To make sure I'm running the latest version, I downloaded and installed the software again today. Same problem.  

    Perhaps the solution for now is to install an old version. If you can provide one, please do. 

    kr.

    Erik

  • LucaseuropaLucaseuropa Posts: 254 Moderator

    Hey @ErikGeurtjens,


    Thank you for your feedback, I will contact you privately to follow-up on the issue you still experience.

    We'll stay in touch 🙂

    Cheers,

    Lucas

Sign In or Register to comment.