Software updater running at 25% CPU for long time everyday

Hi

I have a lot of machines that are running "F-secure Software Updater" using 25% CPU power for 10-30 minutes each day. Looking at the machines in question it only seems to be Windows updates that are missing and I don't push Windows updates via F-secure I do this via WSUS.

What could be the issue here?

My own machine does the same. Only missing some office updates

Accepted Answer

  • MonikaLMonikaL Posts: 182 Moderator
    Accepted Answer

    Hi,

    We have added the option in the PSB profile under software updater tab where you will be able to change the priority.

    This option is visible on the portal as "Scanning priority". This changes the priority of the software updater from "High" to "Low" and that in return uses less CPU. 

    Hope this helps.

Answers

  • MikaArasolaMikaArasola Posts: 30 F-Secure Employee

    There are a few situations when the software updater will be using CPU, though what you are seeing sounds like too much. The most common case would be scanning for missing updates. We have been moving towards a new technology provider for software updates, and currently the scan takes longer then before (previously it took a few minutes with 90% CPU, currently it takes 10-20 minutes with 25-30% CPU).

    With default settings (open profile settings -> Software updater) the "Scan automatically for missing updates" will scan once a day at a random time to discover if there are any missing updates and report them to the backend. Another option on the same page is "Scan on system startup" which performs a scan right after the computer has started. If you have scheduled installations it also checks for newly available updates before installing to ensure the information is up to date. Here you can also exclude Microsoft related updates from being reported by adding to the "Rules to exclude updates from scan results":

    VENDOR=Microsoft

    VENDOR=Microsoft Corporation

    However this will not speed up the detection as filtering happens after scanning.

    We have been building an alternative way to schedule these tasks more flexibly as part of the new Automated tasks. There you can schedule scanning of missing updates (or installations) to happen at your convenience. If you take this into use then remember to disable the scanning under Software updater settings!

    I discussed this with our developers that work on this functionality. They are aware of the change in behaviour and looking into what improvements could be done. One of the things they are testing is lowering the priority of scanning to "background", but this is still being investigated.

  • DannyMalvangDannyMalvang Posts: 10 New Member

    This is what I have been seeing. Users didn't think about the machine being slow for a few minutes at startup but they do notice a load of 25-30% for 20 minutes, especially because the fan starts when the computer is at that load for more than a few minutes.

    if you could lower the scanning priority this would propably solve the problem.

    I have already excluded microsoft updates in all profiles but they do still keep popping up. I have a S4B update that WSUS says no machine needs but F-Secure seems to think almost all my machines need: KB3191937

    BR

    Danny

  • DannyMalvangDannyMalvang Posts: 10 New Member

    Hopefully you are going to fix this somehow, more and more people are contacting us saying their computers are noisy.

    BR

    Danny

  • LSSNickLSSNick Posts: 1 New Member

    Hi There

    Is there any update to this issue?

    My computer is also running at cpu 25% for about 20 min and it is getting really annoying.

  • DannyMalvangDannyMalvang Posts: 10 New Member

    I opened a case with F-Secure and got this answer:

    In regards to the issue you are facing yes we are aware of this I would like to inform that for Business suite of the product we actually have a fix that can be deployed via Policy manager. 

     However for PSB Computer Protection as it's managed from the cloud we don't have a fix for this yet, as the fix that is deployed change the priority of the software updater from "High" to "Low" and that in returns uses less CPU. 

     However, we will soon add an option in the PSB profile under software updater tab where you will be able to change the priority.

     This option will be visible to the user from the portal by end of this month.

     Or temporary you can turn off the Automatica scanning for the missing updates and scan it manually. Or can turn off the whole Software updater feature so it does not consume high CPU. 

    The option is not there yet, but hopefully before January is over this will be there.

  • jameschjamesch Posts: 290 Moderator

    Hi @LSSNick may I know which PSB product and version you are using ?

  • jameschjamesch Posts: 290 Moderator

    Hi @DannyMalvang , I am currently checking this with our developers and will update you.

  • jameschjamesch Posts: 290 Moderator

    Hi @DannyMalvang - I have an update from our developers.

    In a week we will enable "scanning priority" toggle on PSB Portal for everyone.

    So, once we enable the toggle for everyone, customers will be able to set a lower scanning priority.

    And, hopefully, opswat will be able to decrease CPU high usage.

    Laksh
  • DannyMalvangDannyMalvang Posts: 10 New Member

    Excellent, I will be looking forward to this.

  • DannyMalvangDannyMalvang Posts: 10 New Member

    So this did nothing. I can see that it is running in the background now, but it is still using up around 25% CPU power for an extended period and this is still triggering the fan in the machines since it is a continuous load.

    Either you need to revert back to what it did before and do the scan in a short burst. Perhaps this can be done while the machine is on the lock screen, or you need to lower how much CPU power the scan can use.

This discussion has been closed.