Code:256#012FATAL: Failed to get configuration

I would like to know the meaning of "Something wrong in initializing backend. Code:256#012FATAL: Failed to get configuration"

This an extract of my shell script:

quisuisje=$(whoami);

/usr/bin/logger -t Antivirus "Je suis : ${quisuisje}" ;

/usr/bin/logger -t Antivirus "Verification antivirus du média DVDROM" ;

resultat_commande_AV=$(/usr/bin/fsav ${sTmpDir} --action1=report --auto 2>&1)                      ;

/usr/bin/logger -t Antivirus " Résultat du scan F-SECURE: ${resultat_commande_AV}"                  ;

/usr/bin/logger -t Antivirus " média DVDROM vérifié"                  ;


The script is correct when it is started as root or with sudo. The result of the script is below:

Apr 28 01:14:47 sage-1 Antivirus: Je suis : root

Apr 28 01:14:47 sage-1 Antivirus: Verification antivirus du média DVDROM

Apr 28 01:14:48 sage-1 Antivirus: Résultat du scan F-SECURE: F-Secure Anti-Virus CLI version 1.0 build 0069#012#012Scan started at Tue Apr 28 01:14:47 2020#012Database version: 2016-11-02_01#012#012/tmp/Scan_Antivirus.RoXp/EICAR: Infected: EICAR_Test_File [FSE]#012#012Scan ended at Tue Apr 28 01:14:48 2020#0122 files scanned#0121 file infected

Apr 28 01:14:48 sage-1 Antivirus: média DVDROM vérifié


But when this script is started from an udev rule, I've got the following stderr output:

Apr 28 01:15:41 sage-1 Antivirus: Je suis : root

Apr 28 01:15:41 sage-1 Antivirus: Verification antivirus du média DVDROM

Apr 28 01:15:41 sage-1 Antivirus: Résultat du scan F-SECURE: Something wrong in initializing backend. Code:256#012FATAL: Failed to get configuration

Apr 28 01:15:41 sage-1 Antivirus: média DVDROM vérifié

I tried to find answer with "man fsav" but no result. I've found something about "open configuration file", dabase

Any idea ?

Philippe

Answers

  • JaimsJaims Posts: 395 Moderator
    edited May 1

    Hi Philippe,

    Could you please let us know which F-Secure product that you are using and what exactly were you trying to do when you got the error code?

  • OpaleOpale Posts: 2

    Hello Jaims,

    I use Fsecure V11.10 build68

    For the interface Management Agent : 4.75 build 79

    In a simple script I call this command (just the extract of the fsecure command) :

    ....
    
    /usr/bin/fsav/media/cdrom--action1=report--auto
    
    ....
    


    When this script is started as root or with sudo rights, there is no error : OK

    But when I add this script an udev rules, the script is perfectly call by the udev rule and fsav exits with a stderr error :

    Something wrong in initializing backend. Code:256#012FATAL: Failed to get configuration


    I've checked the rights by adding a unix command inside the script: 'whoami' returns root. So it doesn't seem be a problem of rights....


    This is my udev rule:

      KERNEL== “sr0“ SUBSYSTEMS== “block“ RUN+="/usr/bin/my_script"
    


    What's wrong with that ?

    Thanks a lot.

    Philippe

Sign In or Register to comment.