F-Secure interfering with visual studio code

I have tried to compile and run a simple 50 line program in visual studio code.

 

However, it took me over 3 minutes to compile and run. 

 

Once I have unloaded F-secure, my code compiles and runs instantly.

 

Can someone please help me with this issue? I cannot unload F-secure all the time while I am coding, then I will lose the point of using F-secure.

 

Comments

  • UkkoUkko Posts: 3,021 Superuser

    Hello,

     

    I am only an F-Secure user (their home solutions).

     

    Perhaps, you could try to reach out their official Support Channel (for example, web-chat):

    Support Agents with an ability to troubleshoot further and to analyze situation much more better.

     

    But as a workaround - you can try to use "Exclusion list" (not recommended).

    For example, to add compilation folder to list of exclusions or Visual Studio folder itself. Need to verify what can be helpful there.

    In general, you could also try to disable certain feature (for example, real-time scanning OR ransomware protection, DeepGuard to surely understand what is the main reason).

     

    Thanks! 

  • MonikaLMonikaL Posts: 106 Moderator

    Hi,

     

    Could you please provide details of the F-Secure product you are using.

     

    Regards,

    Monika

    Ukko
  • Dear MonikaL, 

     

    I am using F-Secure client security premium.

    Please let me know, what other information can I provide for you?

    image.png

     

  • Thank you Ukko!
    I've asked on the official support channel and is waiting for their reply.
    Tried your exclusion list as well, not working as good as unloading though. There might be another solution! Thanks
  • ms113ms113 Posts: 1

    Have you recieved a solution, I have the same problem and would appreciate any advice?

Sign In or Register to comment.