After server / policy manager upgrade to 14.30 PM slow - waiting for server

Hello

 

After upgrade server and Policy Manager to 14.30 when I am connected from workstation I notice that there is some delay when moving from item to item and on lower left corner is written message: Waiting for server. 

 

For some items (computer, option...) after choosing them, going to next one and return to previous it seems ok and fast (probably because of caching) but for some of them or items when I first click on them it is still slow and I must wait.

 

Anyone have same experiance ? Any advice ?

 

Thank you

 

Regards

Nenad

Answers

  • MonikaLMonikaL Posts: 79

    Hi Cnenad,


    It seems there are two problems here: Hosts lack of Policy Manager (Domain Tree) and it sounds like there are too many alarms.

     

    Missing Hosts:
    In the domain tree, you will see the hosts that has been synchronized with your AD.
    If there are missing Hosts, you can create a synchronization rule, to keep the Client list up to date.

     

    Alarm view causes PMC to freeze:
    You might have to many alerts generated from Clients, and never cleaned up.
    You can clean up the alerts from PMC view, to do so:
    Open the Policy Manager Console and navigate to Tools and F-Secure Policy Manager Sever Configuration then Alerts and reports. Here you can clean up all alerts that are older than example 2 days.

     

    Regards,
    Monika

  • CNenadCNenad Posts: 7

    Hello Monika,

     

    Thank you for reply.

     

    Everything was ok before upgrade to 14.30

     

    Almost same number of alarms then and now.

     

    Regards

    Nenad

  • MJ-perCompMJ-perComp Posts: 1,098
    How many CPUs did you assign to the server?
  • strostro Posts: 6

    Hi,

     

    same problem here - at least we did the update to 14.40 ... 

    We had such issues already in the past and the workaround was to provide more virtual resources (more CPU, more RAM). After this all was working well - until the last update.

    Now we spent even more resources to the VM > 2cores/4 sockets + 12GB RAM ... but it changed nothing ... every click in PM results in a freeze of 10-20seconds.

     

    And yes, the performance tweaks in the registry for the Java process was already done ...

     

    Kind regards

     
  • jameschjamesch Posts: 100

    Hi stro

     

    We suggest to  remove any "performance tweaks" as they are not needed. Java works fine without them on hosts with enough RAM.

     

    For console monitoring on PM 14 and newer, it is started using a different method:

     

    - Modify level for serverRequests logger from "off" to "info" in c:\Program Files (x86)\F-Secure\Administrator\conf\fspmc-logging.conf.xml or /opt/f-secure/fspmc/conf/fspmc-logging.conf.xml

    - Start the console and browse several tabs and views

    - Collect c:\Program Files (x86)\F-Secure\Administrator\logs\server-request.log or /opt/f-secure/fspmc/logs/server-request.log

  • strostro Posts: 6

    Hi,

     

    thank you for your quick answer!

    I raised log level, restarted the PM service on the server and started the console.

    Starting up the console takes about 2minutes or longer(!). Find the logs here: https://pastebin.com/b0tX8RYa

     

    With "tweaks" I meant the starting parameters for Java:

    -Xmx2048M -DmaxUploadedPackageSize=10485760 -DallowUnsignedWithRiwsAndMibs=true

    Which of those arguments could be removed?

     

  • jameschjamesch Posts: 100

    Hi stro

     

    -DallowUnsignedWithRiwsAndMibs=true  and -Xmx2048M  should be dropped

     

    According to PMC request log, server behaves really  bad, it takes seconds even on quick requests.

     

    We suggest to run maintenance tool, check host performance if anything is heavily using CPU, RAM or disk IO.

     

    If maintenance tool does not help and host performance (with stopped PMS host behaves well) is OK, we suggest to contact support directly with FSDiag

  • strostro Posts: 6

    what is meant with "maintenance tool"?

  • jameschjamesch Posts: 100

    Hi stro

     

    During the PM upgrade, there is an option to backup your database using maintenance tool.

     

    If you did not run maintenance tool from setup, you can follow the steps below to troubleshoot performance or slowness issues: 

    1. Make sure your server meets the requirements. Please refer to the latest release notes about the Version you are using: https://help.f-secure.com/product.html#business/releasenotes-business/latest/en/fspm-latest-en 
    2. Cancelall the operations you might have running on the Policy Manager Server. You can find the option in the main menu in Policy Manager Console. 
    3. Check the Database size C:\Program Files (x86)\F-Secure\Management Server 5\data\h2db\fspms.h2 
    4. Backup your fspms.h2 Policy Manager Database first.The database is located in C:\Program Files (x86)\F-Secure\Management Server 5\data\h2db 
    5. Run the fspms-db-maintenance-tool. You can find the Tool in the installation folder: C:\Program Files (x86)\F-Secure\Management Server 5\bin 
    6. If the maintenance tool fails,  run fspms-db-recover. You can refer to the README-recover-db how to run the tool and its option. The files are located in: C:\Program Files (x86)\F-Secure\Management Server 5\bin 
  • CNenadCNenad Posts: 7

    Hello,

    same as before, 4 vCPU. That should not be reason for slow PM.

    After clearing logs and events in PM now it is ok and we do not have any slow responses when moving from computer to computer in PM console.

    Regards

    Nenad

Sign In or Register to comment.