Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

kernel failure on installation

Dear F-secure team,

 

I am trying to install version 11 of F-secure onto a Ubuntu 18.04.3 64-bit machine. On launching

 sudo ./f-secure-linux-security-10.20.358 

It launches and then I get:

 

Running /opt/f-secure/fsav/bin/fsav-compile-drivers

Compiling dazuko driver for kernel version 4.13.0-16-generic
dazuko configure failed. See output in /tmp/dazuko.ggvYec/configure.output
Compiling redirfs driver for kernel version 4.13.0-16-generic
redirfs configure failed. See output in /tmp/redirfs.E35FOo/configure.output
Compiling dazuko driver for kernel version 4.15.0-65-generic
dazuko configure failed. See output in /tmp/dazuko.ulWZ49/configure.output
Compiling redirfs driver for kernel version 4.15.0-65-generic
redirfs configure failed. See output in /tmp/redirfs.2ynFba/configure.output
No kernel modules compiled! Real-time protection features will not work!
Installation finished.

*** NOTE *** NOTE *** NOTE *** NOTE *** NOTE *** NOTE *** NOTE ***

FSAV kernel driver failed to compile.
Please fix the errors printed above, then run as root:
/opt/f-secure/fsav/bin/fsav-compile-drivers
Without kernel drivers the realtime protection features will not work!
After drivers have been successfully compiled, restart daemons with command:
/etc/init.d/fsma stop ; /etc/init.d/fsma start

*** NOTE *** NOTE *** NOTE *** NOTE *** NOTE *** NOTE *** NOTE ***

 

I'm not sure what the next steps should be?

 

Many thanks - apologies I am a relative newcomer to linux.

 

All the best

 

Comments

  • jameschjamesch Posts: 143 Moderator

    Hi Tac

     

    Can you please check that the required packages for Linux Security are already installed. You could refer to the following community article for the detail information about the required packages.

    https://community.f-secure.com/t5/Business-Suite/Pre-installation-checklist-for-F/ta-p/76128

     

    For Ubuntu 18.04, the following needs to installed.

     

    sudo apt-get install libc6-dev:i386 libpam-modules:i386 libstdc++6:i386 rpm zlib1g:i386
  • tactac Posts: 3

    I tried your helpful suggestion but still keep getting the same error. Your help would be much appreciated. 

     

    Many thanks 

     

    Running /opt/f-secure/fsav/bin/fsav-compile-drivers

    Compiling dazuko driver for kernel version 4.15.0-66-generic
    dazuko configure failed. See output in /tmp/dazuko.3I9aF8/configure.output
    Compiling redirfs driver for kernel version 4.15.0-66-generic
    redirfs configure failed. See output in /tmp/redirfs.yUU6fR/configure.output
    Compiling dazuko driver for kernel version 4.15.0-69-generic
    dazuko configure failed. See output in /tmp/dazuko.Bnj0qD/configure.output
    Compiling redirfs driver for kernel version 4.15.0-69-generic
    redirfs configure failed. See output in /tmp/redirfs.Xm30VL/configure.output
    Compiling dazuko driver for kernel version 4.15.0-70-generic
    dazuko configure failed. See output in /tmp/dazuko.yyXNWW/configure.output
    Compiling redirfs driver for kernel version 4.15.0-70-generic
    redirfs configure failed. See output in /tmp/redirfs.Igf6HV/configure.output
    No kernel modules compiled! Real-time protection features will not work!
    Installation finished.

     

    All the best

  • Sami_JSami_J Posts: 17 F-Secure Employee

    The command example and the redirfs errors you provided tells that you are using Linux Security 10.20 installer. LS 10.20 does not support Ubuntu 18. To install Linux Security 11.10 use its own installer.

  • tactac Posts: 3

    Dear Sami, 

     

    I have installed this through the University College London account - do you know if the university has a licence for the new version? 

     

    Many thanks 

  • Sami_JSami_J Posts: 17 F-Secure Employee

    Hi tac,

     

    Sorry, I have no access to such information and disclosing it here might not be reasonable either.

    Anyway, for LS11 you need a new license key that you should ask directly from the university in case they have a license. LS11 also has a trial period which you can use to try out the product.

This discussion has been closed.