Connection Control HyperV Local Virtual Machine

Hi I have a customer who needs Connection control on - They also have a local Virtual machine running on there desktop (Hyper V) When they enter the banking app it disconects the VM and reconnects it The user is then presented with the lock screen on the VM. So they have to re-enter there password.

 

This is just annoying for the users - I have tried adding the IP Addresses of the VM's into the Trusted Hosts section but this does not seem to work.

 

If anyone has any thoughts on this that would be great.

Comments

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Adding the VM as trusted host is wrong.
    Options:
    1) Add the hosts (webservers) that the VM connects to to "trusted sites" in the machine that hosts the hypervisor.
    2) change the VM-Network profile from NAT to Bridged, so that the VM connects via it's own TCP-stack

    Bad options:
    3) allow existing connections not to be terminated
    4) switch connection contriol off

  • Thankyou for the advice but I can seem to comlpete options 1 or 2

     

    1. The host is the machine itself a win 10 box with no Web services configured.

    2. This is a hyper-V VM and forgive me i cant seem to find a way to change the network profile from NAT to bridged.

     

    Kind regards

  • This is still an issue for us, has anybody got any suggestions.

  • VadVad Posts: 1,050 F-Secure Employee

    Hello secure00023,

     

    Did you try option 3? Does it help to resolve your issue?

     

    Best regards,

    Vad

  • Hi yes option 3 and 4  work but it bothe options defeat the object.

     

    Kind regards

This discussion has been closed.