Issue removing Offload Server Agent from Windows Server

Hello guys,


i have spent two weeks looking for a solution in the forum, but i had'nt found any...


I have Policy Manager 13.11 and we want to install Server Security on some Windows servers. The problem is my client install OSA by mistake on some devices, so they are reporting now the "no scanner availeable" error.


We have tried to make a "repair" and a reinstallation of the software without "OSA" check, but allways the feature OSA is working on the client.


We tried to uninstall all the software on windows server and reinstall it (by MSI) with only antivirus enabled (no OSA, no DeepGuard). After reboot of the WinServer, F-Secure Server Security started to work fine, and when we cheked it on the Console, OSA appeared not installed. 


The problem is that after a while (over half an hour), the OSA appear installed again on the WinServer, the real-time protection go to disabled, and the error "no scanner available" starts to appear again...


So, we would like to remove OSA from these servers so the installation woks fine and the scanners works on the machine...but we are not able to find a way to...


Please, has this happenned to anyone? some ideas?


Thankyou for the help!

Best Answer

  • VadVad Posts: 1,051 F-Secure Employee
    Accepted Answer

    Hello Escalante,


    First of all, in current versions of Server Security (12.x) the only proper way to remove Offload scanning agent module is to uninstall the product completely and then install it again with deselected OSA module.


    The scenario, which you had described, could happen, if there is still a server product policy based upgrade/installation with OSA module selected configured in PM Console for the domain/sub-domain, where problematic server is located.


    If you fail to locate such upgrade/installation in PMC, you can always contact support, provide diagnostic information from Policy Manager, and one of servers where OSA module appeared later, for analysis, and we will help you to find the root.


    Best regards,




  • EscalanteEscalante Posts: 2

    Thanks you for the response.


    Finally I found that my client's SCCM was installing a bad version of the MSI (with OSA) recursively.


    When we stopped it, we could do the Vad's solution and all work fine.


    Thanks you again.


This discussion has been closed.