Question about master password

I use F-Secure Key on Windows 10 and working ok, until now.

I had a problem with my windows user. Windows was unable to start session and I couldn't recover it. I created a new user and migrated my settings to the new user.

Regarding to F-Secure key I tried to copy files in users/old-user/appdata/local/f-secure to the new user folder.

Now, When I use the master password F-Secure says 'Incorrect password'. When I try to recover the password using the QR code it says the same, 'Incorrect password'.

Is there a way to recover the password using the new windows user?

Thanks.

Best Answer

  • UkkoUkko Posts: 2,999 Superuser
    Accepted Answer

    Hello,

     

    I'm not sure about current builds of F-Secure KEY. But previously it was with such view (and maybe should work).

     

    ->> So, you copied folder/files from "users/old-user/appdata/local/f-secure" (should be enough folder "Pwmgr" or so). With your previous profile and original F-Secure KEY passwords (localstorage).

     

    ->> Then you tried to add such folder/files (should be enough replace "Pwmgr" folder) to your fresh path profile. For example, by steps like -> remove "Pwmgr"-folder from fresh profile (if it was there) -> add your copied "Pwmgr"-folder from your previous profile.

     

    ->> Then you launch F-Secure KEY and it should allow you to use your previous masterpassword.

    But with your situation -> it will prompt that "'Incorrect password'"?

     

    If so -> maybe there are some changes. And I will doublecheck my own experience about it (later). But with my feelings -> your localstorage-file should be valid for fresh profile too. But good to keep multiple backup-files of such (since it can be overwritten eventually) for further checks.

     

    Thanks!

    Tapsuccaabelp

Comments

  • abelpabelp Posts: 2

    Thanks, problem is solved:

    I repetead the process more carefully:

    1. I deteled pwmgr folder in the new profile (Copied in my previous intent).

    2. I stopped F-Secure Key service with the task administrator.

    3. I copied again pwmgr folder and subfolders from the old user profile to the new.

    4. I restarted the computer.

    And checked the master password and Ok!

    Steps 2 and 4 were not done in my previous intent.

    Thanks for your support, Ukko.

     

    UkkoTapsucca
This discussion has been closed.