Install FS AV for Windows Server 2008R2

I have trouble while installing the trial of FS AV for Windows Servers on my 2008R2-Server.


First of all:

I'm not able to enter the given 60day-Trial-Code because there is no field to enter the ke. I know this field from the FSCS but in this release the field seems not to be included...

 

My second problem:

The webinterface seems to be unusable because the console produces certificate errors like described in the manual. After creating the certificate manually, the certificate can't be installed ( there is no option in my IE). So I tried to import the certificate manually via Import in the "Internet options". The certificate import says "successfully miported" but the certificate isn't visible at all.

The loading of the webinterface doesn't work at this time.

 

Any suggestions?

Thanks in advance

Best Answer

Comments

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Hi,

     

    which installer did yo use?

     

    did you try to access the WebUI from a Workstation?

  • GummibeereGummibeere Posts: 18

    I used the last install available on the webclub...

    http://download.f-secure.com/webclub/fsavsrv900.exe

     

    I tried to access the webpase from the server as well as from any workstation. Same issue..trying to access from workstation the site seems to be loading and loading and loading...

     

    Hm. Really strange problems... Smiley Sad

  • DmitriyDmitriy Posts: 212 F-Secure Employee

     

    First of all:

    I'm not able to enter the given 60day-Trial-Code because there is no field to enter the ke. I know this field from the FSCS but in this release the field seems not to be included...

     


    The setup package of the evaluation version of FSAV for Windows Server comes with the keycode hardcoded and thus you can't see or change it during installation. It is possible to change the keycode after installation, though.

     

    My second problem:

    The webinterface seems to be unusable because the console produces certificate errors like described in the manual. After creating the certificate manually, the certificate can't be installed ( there is no option in my IE). 

     

    How exactly did you create the certificate manually? Note that in order to have the proper certificate and eliminate web browser warnings, you should get it issued by  one of the root/known CAs.

     

    So I tried to import the certificate manually via Import in the "Internet options". The certificate import says "successfully miported" but the certificate isn't visible at all.

    The loading of the webinterface doesn't work at this time.

     

    Which IE do you use?

     

  • PeterPeter Posts: 186 F-Secure Product Expert


    Note, if you are OK with a self-generated certificate, try starting clean by invalidating the current one. This should at least fix the issue with Web UI not working at all, as seems to be the case now.

    To invalidate the certificate and start clean, use makecert.bat:

    \program files\f-secure\web user interface\makecert.bat
    net stop "f-secure webui daemon"
    net start ""f-secure webui daemon"

    The browser should again display the WEB UI with the certificate error. The "view certificates" option is available when clicking on the actual error in IE and for the rest, following the manual instructions should do the trick:

    Page 16, "Log in and install the security certificate).

    Admin guide:

    http://www.f-secure.com/en/c/document_library/get_file?uuid=ee651676-27e4-4200-850e-4cf208dd7be6&groupId=30743

    Note also, at least with IE7 you need to restart the browser for the "certificate error" to (finally) dissappear after installation of certificate.

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Hi,

     

    general Question: wouldn't it make more sense to authorize the CLIENT (IE or FF) or even the user against the server but vice-versa?

     

    BR

     

  • GummibeereGummibeere Posts: 18

    Thanks for your answers and hints.

    @first problem: this is now solved cause of explanations. Thank you Dimirty!

     

    @econd problem:

    I already created a new certificate with the makecert.bat described in the admins-guide.

     

    Restarting the service doesn't help.

     

    I really guess, the security on the servers browser prevents to load the site. I allready added this page to the secure websites. Hm.

    May it be possible, that the general IE9-Settings prevent loading the page?! If i click on the "Continue loading the site( not recommend" (german translation) the site "res://ieframe.dll" is called.

  • GummibeereGummibeere Posts: 18

    Hey! That hint worked!!


    Finally I can see the F-Secure Website. Yeeeehaa!

     

    Thanks

     

    [SOLVED]

     

    Ps. I created an p12 Certifiakte out of the PEM-File... I imported that created certificate to the root certificate authorities and thats it!

    Thanks again!

This discussion has been closed.