Incorrect time displayed on SENSE Router

This discussion has a more recent version.
Jali Posts: 1,769 F-Secure Employee


Normally, after the setup is finished, F-Secure SENSE Router shows the current time on its display. It keeps time by synchronizing the clock regularly with the time server. When the SENSE Router is turned on, the clock may initially be out of sync.


The reason for this is that the device does not have a battery backup for keeping the time when the device is turned off. F-Secure SENSE Router will automatically update and adjust the time as soon as it connects to the Internet.

If the SENSE Router clock appears to be off permanently by a specific amount of time even if it is connected to the internet, it is possible that the time zone configuration is incorrect. F-Secure SENSE Router gets the time zone configuration from the device used during the setup. It is not yet possible to adjust it from the application after the setup but this feature is on our list of forthcoming improvements and will be available as an update.


To fix the issue:

  1. Make sure that the device that you use for the setup is set to the correct time zone and that it shows the correct time.
  2. Reset both the SENSE Router device and the SENSE Router application, and run the setup again.

    Note: You can use the same SSID and password when setting up F-Secure SENSE Router again to have all your devices automatically re-connect to the network.