Services may not be automatically started when upgrading from F-Secure Internet Gatekeeper 5.xx to

This discussion has a more recent version.
Jali Posts: 1,769 F-Secure Employee


When you upgrade F-Secure Internet Gatekeeper from version 5.xx to version 5.40, services may not be automatically started.


The following operating systems are affected: CentOS/RHEL 7, Debian 8, Ubuntu 16.04 and SLES 12.

Internet Gatekeeper 5.40 introduces native support for

. In the previous releases, the services were managed by SysV-style init scripts.

attempts to provide backward compatibility with the SysV init scripts. While
is aware of the product services, it may not be able to report the correct status when the services are started or stopped after a restart. This may cause that the enabled services are not automatically started when the product is upgraded.


There are two optional ways to solve the issue:

  • Restart the machine. This allows
    to load the configuration and manage the services automatically according to the product configuration set in the Internet Gatekeeper Web UI.
  • Start the services manually and refresh
    service statuses. Login to the system and enter the following command as a root user:
    • # systemctl daemon-reload
    • # /opt/f-secure/fsigk/libexec/

      Note: This command must be run outside the product installer directory (fsigk-5.40.73)!

Note: CentOS/RHEL 7.2 users and other platforms using

version 219-19.el7 or similar: Due to a change (see how
handles SysV-style init scripts, the product services were not starting automatically at restart. If you have added a workaround, for example by replacing the init script symlinks in /etc/init.d/ by regular files, or by starting the services via /etc/rc.local, it should be removed after upgrading to product version 5.40.