Unable login to F-Secure Email and Server Security 14.00 Web Console, error "Transport Agent status

This discussion has a more recent version.

Issue:

  • F-Secure Email and Server Security Microsoft Exchange transport agent can not be started after upgrading to version 14.00
  • F-Secure Email and Server Security Web Console shows "Transport Agent status is not available. Check the configuration of F-Secure Email and Server Security services and try again."

Resolution:

Before you go any further with the troubleshooting, please make sure that the client is connecting to the F-Secure Policy Manager Server.
In case your Policy Manager Server is turned off, or the connectivity between the Client and Policy Manager is not working, WebUI can not show some of the settings right after the upgrade or installation, as generally these settings are coming from Policy Manager right after installation.

If the connectivity is ok, please follow the steps bellow to possibly solve your problem:

Run the following command in Exchange management shell to verify if F-Secure Transport Agent is enabled: Get-TransportAgent

Example result:
 

User-added image
 
If F-Secure Transport Agent is "Enabled" = "True" then the following notes should be taken into account on why you are encountering the error:
  • You have clicked CANCEL in login prompt or hit OK too many times
  • You couldn't log in accordingly because the browser is not launched with admin rights

To fix the problem, do the following:

  1. Launch your preferred browser with the Run as administrator option
  2. Enter your admin credentials when prompted
  3. Log in to F-Secure Email and Server Security Web Console using the same admin credentials

Note:

  • By default using a link from the start menu or typing the IP address in the address bar, means that the browser is still running with user-level rights. Even if it was launched by admin's double click. F-Secure Email and Server Security Web Console could not ask for elevation after the login prompt is shown.
  • Launching the browser by double click will only work if User Account Control (UAC) is turned OFF and in policies approval mode is disabled. Otherwise, you need to start the browser as admin.
As a workaround, you can do the following:
  1. Launch a browser from another host in the network
  2. Go to https:\\<your_server_ip address>:25023
  3. Log in with the domain admininstrator user credentials
If non of the instructions above  helped, you can can uninstall Transport agent as follows:

Open ems Exchange Management Shell and execute the following PowerShell cmdlet:
  1. Get-TransportAgent
  2. Disable-TransportAgent -Identity " F-Secure Transport Agent"
  3. Uninstall-TransportAgent -Identity "F-Secure Transport Agent"
  4. Run the MSI on the target server, this should solve the issue (MSI can be exported from Policy Manager Server, for more info please refer to this Community article)

Note: To access the web console from other hosts in the network, you need to allow them via Internet Information Services (IIS). Refer to F-Secure Email and Server Security 14.00 admin guide1.3.3 Allowing hosts to access the web console

Important: If you are using Microsoft Exchange Server 2013 w/o service pack, service pack 1 (CU23, CU22, CU21). The cumulative updates (CU) that support .NET Framework 4.7.2 are indicated in parentheses. For more detailed information, see https://docs.microsoft.com/en-us/Exchange/plan-and-deploy/supportability-matrix?view=exchserver-2019#microsoft-net-framework. Microsoft Exchange Server 2013 SP1 requires a special fix, which allows third-party or custom-developed transport agents to be installed correctly. The fix and its installation instructions are available in below link.
https://support.microsoft.com/en-in/help/2938053/third-party-transport-agents-cannot-be-loaded-correctly-in-exchange-se

Article no: 000018909

Sign In or Register to comment.