F-Secure PSB Computer Protection for Mac installation fails due to product not being compatible with

Issue:

Installation of F-Secure PSB Computer Protection for Mac fails with error message: "product is not compatible with com.mcafee.menulet."
 

Resolution:

It is advised to disable password and tamper protection for McAfee Business End Point Products to allow F-Secure Sidegrade feature to work. Steps on how to uninstall McAfee can be found from the page: https://community.mcafee.com/t5/Mac-and-Linux-Products/How-to-uninstall-McAfee-Endpoint-Security-for-Mac/td-p/511441

If uninstallation is still unsuccessful, you may need to seek uninstallation assistance from McAfee. 

Article no: 000018279

Sign In or Register to comment.