Delphi debugger process crashes with F-Secure Client Security installed

Issue:

With F-Secure Client Security installed in the host, the Delphi debugger process does not work or crash

Resolution:

We recommend to do the following workaround:

  1. Add the exclusion for the Delphi software executable (for example, C:\Program Files (x86)\Embarcadero\Studio\17.0\bin\bds.exe, etc.) in DeepGuard under the Advanced View in the Policy Manager Console:
  • F-Secure DeepGuard > Settings > Excluded Applications (using full file path of the Delphi software executable)
  • F-Secure DeepGuard > Settings > Applications (using a SHA1 hash of the Delphi software executable)
NOTE:
  • If you are using Client Security 13.10 or older, you shall upgrade to the latest Client Security 13.11 and above to allow Excluded Applications to work.
  • If you are using Client Security 14.00 - 14.02, we recommend you upgrade to the latest Client Security 14.10 to resolve the issue with exclusions.
  1. Launch an elevated command prompt and type the following one after another:
  • net stop fsulhoster
  • net stop "F-Secure gatekeeper"
  1. Create the following entry below under the registry HKLM\SYSTEM\CurrentControlSet\Services\F-Secure Gatekeeper\Parameters:
  • DisableCompanionWait(DWORD) = 1
  1. In the elevated command prompt, type the following one after another:
  • net start "F-Secure gatekeeper", and ensure that the Gatekeeper driver starts successfully.
  • net start fsulhoster
NOTE:
  1. The provided registry change disables a certain optimization in the F-Secure Gatekeeper driver, which are incompatible with software that tries to suspend processes (ie. Delphi debugger).
  2. This registry key does not alter the enabled features or other functionalities of the F-Secure product.

Article no: 000003035

Sign In or Register to comment.