F-Secure Client Security 14.10 is not installing updates "Update check failed, error=115 (operation

This discussion has a more recent version.
Customer_CareCustomer_Care Posts: 548 F-Secure Employee

Issue:

  • After updating to Server Security Premium 14.00, a group of servers are not getting Virus Definitions
  • After upgrading to Client Security 14.10, clients are not getting updates from Policy Manager Server

Resolution:

If you are facing this issue with Client Security 14.10 upgrade to Client Security 14.21 or later.
In the event that you are facing this issue with Server Security 14.00, open a support request here and request the hotfix FSCS1410-HF07 to resolve the issue.


To confirm you are experiencing the same problem, try opening the following logs from affected Client and investigate them. Logs are usually located in the following path: C:\ProgramData\F-Secure 

  • Open the C:\ProgramData\F-Secure\Log\AUA.log and scroll down to the latest event to see if you have a similar error:

2019-09-23 15:17:09.502 [0e50.1388] I: Connecting to updateserver:80/guts2 (proxy proxy.demo.com:8888)
2019-09-23 15:17:09.517 [0e50.1388] I: Update check failed, error=115 (operation in progress)
  • Open the C:\ProgramData\F-Secure\Log\CCF\Guts2Plugin.log  and scroll down to the latest event to see if you have a similar error:
2019-10-01 09:54:30.351 [1284.1258] I: Guts2Client::UpdateCurrentProxyForRootServer: Save successful proxy 'proxy.demo.com:8888'
2019-10-01 09:54:30.352 [1284.1258] I: Guts2Client::CheckForUpdatesFromServer: Check from server 'fsms:80/guts2'
2019-10-01 09:54:30.365 [1284.1258] I: Guts2Client::RefreshAvailablePackages: Trying with proxy 'proxy.demo.com:8888'
2019-10-01 09:54:30.581 [1284.1258] I: [fslib] server returned HTTP status code 503 (try again later)
2019-10-01 09:54:30.581 [1284.1258] *E: [fslib] unable to fetch update information from the server, error 115 (operation in progress)
2019-10-01 09:54:30.581 [1284.1258] I: Guts2Client::RefreshAvailablePackagesProxyConfigured: Failed to refresh available packages, error=115
2019-10-01 09:54:30.581 [1284.1258] *E: Guts2Client::CheckForUpdatesFromServer: Failed to refresh available updates list
2019-10-01 09:54:30.587 [1284.1258] I: CCFGuts2Plugin::ScheduleCheck: Scheduling next check in 156 seconds

Under the F-Secure Automatic Updates Agent > HTTP  Settings > Use HTTP Proxy and set it to No. Deploy the policy. 

User-added image

If the changes you made now worked, make sure to enable your HTTP-Proxy to <updateserveraddress>:80 (:443)



 

Article no: 000015249

Sign In or Register to comment.