Why is there no internet connection on my computer when F-Secure FREEDOME VPN protection is turned O

This discussion has a more recent version.

Issue:

Why is there no internet connection on my computer when F-Secure FREEDOME VPN protection is turned ON?

Resolution:

To try to fix the issue, reset the DNS cache on your computer.

How to reset DNS cache on a Windows computer:

Open the command prompt as an administrator. Click the Windows start button > type "cmd" > Right-click Command Prompt > Click Run as Administrator.

In the Command prompt, type the commands below. After each command, press Enter to execute.

  • ipconfig /flushdns
  • netsh winsock reset
  • netsh int ipv6 reset
You can restart your machine and check again.

If the above steps do not help, the issue might be that your firewall is blocking the connection.
If that is the case, you need to change your firewall settings to allow the connection.

Our Android, Windows and macOS products use the OpenVPN protocol.
The ports for Android, Mac, and Windows are:
  • TCP/UDP ports in the range 2700 - 2800
  • TCP port 443
Please allow traffic on these ports in your firewall and try to connect Freedome again. 
Refer to this video on how to open Windows Firewall and configure the ports: https://www.tomshardware.com/news/how-to-open-firewall-ports-in-windows-10,36451.html

Please check if automatic killswitch is enabled. Here's how to check.
  1. Open Freedome
  2. Click Settings
The automatic killswitch is the 4th button under Connection & Status. If it is turned on,
  1. Click Allow connections to other devices in trusted networks
  2. Check the network you're currently connected to
  3. Click Save
User-added image

Please also try the following:
1. Uninstall F-Secure Freedome VPN
2. Restart the computer
3. Remove driver with pnputil
4. Restart the computer
5. Install F-Secure Fredome VPN

Article no: 000006587

Sign In or Register to comment.