F-Secure SAFE installation for Mac gives error "JavaScriptError"

This discussion has a more recent version.

Issue:

I can't install F-Secure SAFE on my Mac. I get the error "There was an error reading the package. JavaScriptError".

Resolution:

The error you receive is due to an outdated version of MacOS. F-Secure SAFE supports version 10.12 (Sierra) or newer.
To update your operating system to the latest version:

  1. Click the Apple icon on the top-left corner of the screen.
  2. Click About this Mac.
  3. Select Software Update.
Allow your Mac to update itself to the latest MacOS version. Once completed, restart your Mac and proceed to install F-Secure SAFE.

Article no: 000013419

Sign In or Register to comment.