Firefox blocked or disabled Browsing Protection. Error message - could not be verified for use in Fi

Issue:

Firefox blocked or disabled Browsing Protection. Error message - could not be verified for use in Firefox and has been disabled

Resolution:

This is a bug triggered on 4th May 2019 and currently being fixed by Firefox team. This bug has disabled a lot of add-ons and F-Secure is one of them.

A temporary workaround has been released: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

Article no: 000011784

Sign In or Register to comment.